Qlik Community

Qlik Server Side Extensions Discussions

Discussion Board for collaboration on Server-Side Extensions and Advanced Analytics Integration.

Highlighted
Partner
Partner

Qlikview can't communicate with R (SSE Plugin)

Hi everyone,

I'm having problems installing the R plugin (Link: sse-r-plugin/GetStarted.md at master · qlik-oss/sse-r-plugin · GitHub) in the client machine.

I've installed R, Rstudio, the Rserve library and I downloaded the plugin.

I've launched everything manually (first the Rserve and then the SSE), I updated the settings.ini in the AppData Folder, also in the Qlikview Server as well, I stoped and started the services, and nothing, there is no single line passing through the SSE.

The client has another machine (built for the purpose of testings with the data science team) and the settings are the same, everything looks the same, but in that machine it runs.

I've also done the installation in my local machine (for the purpose of testing) and everything runs perfectly.


Can anyone point me towards problems I could have ?


Thank you!


Best regards!

1 Solution

Accepted Solutions
Partner
Partner

Re: Qlikview can't communicate with R (SSE Plugin)

To who follows the get started , although a bit confusing, that get started explains everything.

In this case, and probably it won't affect any users, WATCH OUT for your Qlikview version.

In this case, it was the 12.10 and the plugin doesn't work with that version. Upgraded to the November 2017 version and it works. Simple solution!

9 Replies
maxim_senin
Contributor III

Re: Qlikview can't communicate with R (SSE Plugin)

Hi,

I have the same issue, R.* function does not work in a QlikVeiw chart (Nov. 2017 SR2), Rserve and SSE starts normal. Rserve_d says the following when starting:

Loading config file Rserv.cfg

Failed to find config file Rserv.cfg

Rserve: Ok, ready to answer queries.

But SSE finally says "gRPC listening on port 50051".

What can go wrong?

Thanks.

Partner
Partner

Re: Qlikview can't communicate with R (SSE Plugin)

Hi Maxim,

I actually get the same message when I run the Debug mode but it still works.

I also saw the same in a clients configuration and no problems were found, so... nothing can go wrong.

Partner
Partner

Re: Qlikview can't communicate with R (SSE Plugin)

I'm sorry Maxim, only read the last part of the message.

Tell me something:

You're using qlikview desktop? did you changed the settings.ini?

does the R code appear in red like you're having a sintaxe error??

maxim_senin
Contributor III

Re: Qlikview can't communicate with R (SSE Plugin)

Hi Frederico,

Yes I use QV Desktop (but am going to use the R with QVS) and I've changed the settings.ini file.

The R code in the chart's expression is underlined with red waves...

Partner
Partner

Re: Qlikview can't communicate with R (SSE Plugin)

Ok we can configure both if you have them.

Did you changed the settings.ini on both Qlikview and Qliksense?

Qliksense location file -> C:\Users\XXX\Documents\Qlik\Sense\settings.ini

Qlikview location file -> C:\Users\XXX\AppData\Roaming\QlikTech\QlikView\settings.ini

Here, you place the following:

[Settings 7] (this is already there)

SSEPlugin=R,localhost:50051

since you're not using Qlikview Server, close the Qlikview app, run Rserve, Run SSEToRserve and then Qlikview.

Tell me if it worked.

maxim_senin
Contributor III

Re: Qlikview can't communicate with R (SSE Plugin)

Hi Frederico,

Wow! Wow! Wow! That works!

Thank you very much, I must be missed the settings.ini in the profile folder.

Have a good day.

Partner
Partner

Re: Qlikview can't communicate with R (SSE Plugin)

No problem !

Glad I could help.

Best regards!

Partner
Partner

Re: Qlikview can't communicate with R (SSE Plugin)

To who follows the get started , although a bit confusing, that get started explains everything.

In this case, and probably it won't affect any users, WATCH OUT for your Qlikview version.

In this case, it was the 12.10 and the plugin doesn't work with that version. Upgraded to the November 2017 version and it works. Simple solution!

Partner
Partner

Re: Qlikview can't communicate with R (SSE Plugin)

Hi Everyone, 

I have configured : 

1) Rserve   2) SSEtoRserve  3) put right path in loadscript in qliksense but got parsing errors as follows : 

May I ask what is issue causing this to be fixed ? thanks 

Error in Qliksense.PNGError SSEtoRserve.PNG