Qlik Community

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Announcements
Join “Do More With Qlik” with Mike Tarallo to get a first-hand look at the New Authoring Experience, June 29th: REGISTER HERE
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Access point unavailable

Qlikview access point is unavailable.

Running Qlikview server 11.0.11154.0

on Windows Server 2008 R2 Datacenter (SP1)

using IIS in stead of Qlikview webserver

.NET framework v4 is active and registered with IIS

IIS Qlikview website is active and accessible on port 80 (http).

Qlikview services are up and running (retried multiple restarts)

Documents are accessible through desktop client with 'open in server'

Access point shows "Loading content" but is stuck there and doesn't ask for authentication

This has happened before and had been resolved without knowing the exact solution...

Any help on this is highly appreciated !

Best regards,

Erwin.

1 Solution

Accepted Solutions
flipside
Specialist II
Specialist II

I notice the QV Webserver in your screenshot is set to Automatic so if you have rebooted did it start and you then stopped it? My system is the other way round, I don't use IIS, but a reboot following a Microsoft update started the Server Settings service (installed as default automatic startup) which stopped my QVWS  running.  I had to disable the server settings service.

There's more in this link (see Bjorn's comment on Nov 25, 2010)...

http://community.qlik.com/message/14217#14217

flipside

View solution in original post

10 Replies
Not applicable
Author

Not applicable
Author

Already tried and checked and double-checked everything in this post to no result.

also forgot to mention: firewall is not active, so all ports are open. But just in case they are set to open within firewall anyway...

Not applicable
Author

Do you see the ASP.NET v4.0 and ASP.NET v4.0 Classic application pools in IIS ? If not, run the reg_iis command in the link.

Does it work when logged locally onto the AccessPoint using http://localhost/qlikview ?

Not applicable
Author

using localhost/qlikview directly on the server, I get the same page with 'loading content'.

Only here the load bar doesn't even move (no animation...)

Below you can see the application pool as it's set right now.

I've changed the Default to v4.0 framework, and tried switching the Qlikview IIS managed pipeline from Integrated to Classic and back.

Qlikview IIS application pool.jpg

EDIT: when I try to run the regiis command it keeps telling me this:

Changing IIS ApplicationHost.config: IIS7Register failed with HRESULT 800700b7: 'Cannot create a file when that file already exists.  '

Not applicable
Author

Run this command and restart IIS or reboot the server : C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe -i

After I ran it, it worked and I could see two additional app pools : ASP.NET v4.0 and ASP.NET v4.0 Classic

Is your 'reporting' user account a member of local and qlikview admins on the server ?

Not applicable
Author

Open a command prompt as 'administrator' and try running the command again ?

Not applicable
Author

I've already ran that exact command multiple times as an administrator.

This doesn't change anything to my application pools even after a restart of IIS.

Just performed a reboot of the system qlikview's running on.

Still the same problem, this is what the application pools look like now:

Qlikview IIS application pool 2.jpg

The reporting user is indeed member of local and qlikview administrator groups.

Not applicable
Author

If your're still getting the error message a quick google came up with this : http://www.eddiedillon.info/?p=274

If it doesn't work I'm afraid it's outta my league 

flipside
Specialist II
Specialist II

I notice the QV Webserver in your screenshot is set to Automatic so if you have rebooted did it start and you then stopped it? My system is the other way round, I don't use IIS, but a reboot following a Microsoft update started the Server Settings service (installed as default automatic startup) which stopped my QVWS  running.  I had to disable the server settings service.

There's more in this link (see Bjorn's comment on Nov 25, 2010)...

http://community.qlik.com/message/14217#14217

flipside