Qlik Community

Ask a Question

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Announcements
Join us at the Cloud Data and Analytics Tour! REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

How to hide QlikViews in AccessPoint?

Hi

We have some qlikviews that will be accessed directly via the URL of its AJAXZFC document. These documents are loaded and distributed via Publisher.

We don't want that these QlikViews are visible in the AccessPoint for anybody. They have to be accessed only via the URL.

Do you know how to do it?

Kind regards,

Kim

15 Replies
Not applicable
Author

As far I know, the only way to hide a documenti in Access Point is to deny access to the user(s) to the phisical file from within Windows.

I don't know if this is feasible in your case.

Rgds

Paolo

Not applicable
Author

You have to use security ACL or mount document folder and unflag "Browse" flag.
bye

Not applicable
Author

I still do not understand what use the option "Browse".
Marked or not, shows ". Qvw" who are in the folder it AccessPoint.
I want to hide some, but I could not yet.
I really need to accomplish this.
I'm using QlikViewServer 9.0.7320.7.

Thank you!

Not applicable
Author

I would like to figure this out also. I tried adding the subfolder with the QVWs that I wanted to hide, unchecked "Browsable", according to Corrado's suggestion, and it didn't have any effect. It would be nice to be able to do it from the QEMC interface without messing around with file system permissions.

Not applicable
Author

I just tried setting DENY to "QlikView Administrators" on a file's permissions within Windows Explorer on the server. It didn't hide the file from my logged in user which is in the "QlikView Administrators" group. Rather, it removed the hyperlink from the thumbnail, and is now displaying "Missing Image" where the thumbnail of the app used to be. It's still showing up in AccessPoint with the filename.

Not applicable
Author

Hi,
unfortunately seems there's a bug on the QV webserver, it show document even in a folder not browsable, sorry.
I've already open a case to QV Support.

Not applicable
Author

Hi,

Thanks for all your answers.

So, it seems that there is no chance to hide the document in AccessPoint.

jsn
Master
Master

Hi,

The visibility of documents in AccessPoint should be controlled by the NTFS permissions on the documents.

I have one Admin account (A) and one user account (B). If I take a vanilla QVS 9 SR2 installation and change the file permissions on Films.qvw to only have the group Administrators listed then user B can't see Films.qvw on the AccessPoint and this is the intended way.

The browsable checkbox controls whether the folder is browsable in the qvp popup dialog, for example when using Open in server or when accessing qvp://servername through a browser to open documents via plugin.

Not applicable
Author

If you are using DMS, it appears all you have to do is go onto the Qlikview Server and check the hidden flag in the properties of the file to make it invisible on the Accesspoint without losing the ability to connect.

UPDATE:  Unfortunately, when you redistribute the file, the hidden attribute is removed from the file.

jg