Qlik Community

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Announcements
Support Case Portal has moved to Qlik Community! Read the FAQs to start exploring Support resources.
cancel
Showing results for 
Search instead for 
Did you mean: 
chapster100
Contributor II
Contributor II

Lease license to Desktop version Version May 2021 from AMP Signed key

Hi All

So my problem is as follows.  We have a QlikView ent server with version May 2021 installed and licensed with a signed key with 60 professional cals and 40 Analyser.

When I open the Desktop version May 2021, or older going back to April 2020, it allows me to "open in server" and connect to the server to open documents, but it does not lease a license to the desktop app on my machine.

I have got the allow license lease check box ticked on the server management console, and the account I connect with from my local machine has a professional cal allocated to it.

So why doesn't it lease the license? Any help would be appreciated.

 

1 Solution

Accepted Solutions
Vikram_Jayakumar

Another reference point QlikView Desktop fails to get license leased. Error code = 0x80041010 or Error code 0x8004100E or 0x...

If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.

View solution in original post

7 Replies
Vikram_Jayakumar

Hi @chapster100 

Custom authentication is worth a try 

1-Open the QlikView Desktop client
2-From the menu, goto Settings > User Preferences
3-Go to the Locations tab and select QlikView Server AccessPoint (URL)
4-Click the Modify... button
5-Enter the URL to the QlikView AccessPoint, configured using Custom Authentication
6-Click OK
7-Click Apply then OK
8-From the menu, go to Tools > Open QlikView AccessPoint
9-Login using the custom credentials
10-Open a document. The license should be now leased from the QlikView Server
11-Close and relaunch QlikView Desktop client. You should now be able to work with local documents and the client is fully licensed

If this does not help and you started seeing this behavior only after starting to use AMP key I would recommend to get in touch with support 

If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
chapster100
Contributor II
Contributor II
Author

Hi

Yes I tried that method too, and still nothing. I am going to double check
today that the 4747 port is open between the server and my local machine.
Perhaps that could be the problem.

Vikram_Jayakumar

Yes along with that couple of points to check 

  • LICENSE_LEASE;NO;; must not be in the LEF
  • TEST_EDITION;YES;; or Special_Edition;TEST;; must not be in the LEF
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
chapster100
Contributor II
Contributor II
Author

hi

I have checked but it isn't layed out like that.  There is no lef file, but a NxLicense.json file that I viewed in notepad.  Nothing in there about licence lease. 

This is the contents of the file:

 

{"licenseNumber":"2580 xxxx xxxx xxxx","valid":"2021-06-30/2024-06-30","blacklisted":false,"deactivated":false,"termsAccepted":true,"allotments":[{"name":"professional","usage":{"class":"assigned","minimum":1},"provisions":[{"qlikSenseDesktop":""},{"qlikSenseMobile":""},{"accessType":"professional"}],"units":[{"count":60,"valid":"./."}]},{"name":"analyzer","usage":{"class":"assigned","minimum":1},"provisions":[{"qlikSenseMobile":""},{"accessType":"analyzer"}],"units":[{"count":40,"valid":"./."}]},{"name":"geoanalytics","usage":{"class":"unlimited","minimum":1},"provisions":[{"geoanalytics":""}],"units":[{"count":1,"valid":"./."}]},{"name":"webconnectors","usage":{"class":"unlimited","minimum":1},"provisions":[{"webconnectors":""}],"units":[{"count":1,"valid":"./."}]}],"features":[{"name":"product","value":"qse","valid":"./."},{"name":"productLevel","value":"50","valid":"./."},{"name":"elastic","value":"true","valid":"./."},{"name":"subscription","value":"true","valid":"2021-06-30/2024-06-30"},{"name":"edition","value":"AMP","valid":"./."},{"name":"qv_nodes","value":"1","valid":"./."},{"name":"qds_nodes","value":"1","valid":"./."},{"name":"delayed_sync","value":"true","valid":"./2021-09-28"}],"parameters":[{"provision":"qvNodes","valid":"./.","values":{"count":1}},{"provision":"officeAddin","valid":"./.","access":{"allotment":"professional"},"values":{"enabled":true}},{"provision":"qlikSenseDesktop","valid":"./.","access":{"allotment":"professional"},"values":{"enabled":true}},{"provision":"geoanalytics","valid":"./.","values":{"geoanalytics":true}},{"provision":"automationTier","valid":"./.","values":{"quantity":1,"value":"2"}}, { "name":"workbench","value":"yes","valid":"" }, { "name":"webparts","value":"yes","valid":"" }],"sourceChecksum":"xxxxxxxxxxxxxxx"}

 

 

Vikram_Jayakumar

Think that looks okay their, you can also get more info on the event logs with something like this "300 Error System: Can't lease license to" 

If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
chapster100
Contributor II
Contributor II
Author

thanks for this tip.  I checked in the application logs on the server and can see an error that  says my local machine does not have a professional cal

 

System: Can't lease license to @ C7531 [397262CC-2E16-11B2-A85C-BEBEA0A4B2A7]: user doesn't have professional license.

The C7531 is the name of my local machine, but the credentials I am using to lease the license has a professional license allocated to it on the server. Perhaps it could be that the server is not inside the active directory domain.

Vikram_Jayakumar

Another reference point QlikView Desktop fails to get license leased. Error code = 0x80041010 or Error code 0x8004100E or 0x...

If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.

View solution in original post