Qlik Community

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Announcements
Customer & Partners, DEC. 9, 11 AM ET: Qlik Product & Strategy Roadmap Session: Data Analytics REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Memory limit to send to excel

Hi,

I have a client that wants to send large reports to excel, but when we try to do it, QlikView is disconnected (lost connection). I think it's a problem with timeout or memory available for this purpose. Is there a way to change these parameters to allow users to download their files?
The same problem arises in send to excel or export to csv option.

We are using qv 9 R5 as Ajax interface on IE.

I thank in advance for your help,

Greetings!
Gabriela

7 Replies
vgutkovsky
Master II
Master II

Gabriela,

You can try to play with the Export Memory limits in QEMC --> System --> QlikView Servers --> Performance. In addition, you can try to create the following DWORD registry value: HKEY_CURRENT_USER\Software\QlikTech\QlikView\Settings 7\ExportMemoryLimit. This value should be set in bytes I believe.

Regards,

Not applicable
Author

Hello Vlad,

Thanks a lot!

I try these option but is not working either.... i look a strange behavoir... seems to be something related to the time, because any report that i try to download, if the export delay more than 1 minute, then the sesion is closed by the server... i review the session time out and is set on 3600 seconds.... do you know if is there another place where this parameter must be set? or is there another parameter to set this?

The parameter on the performance tab are set on:

Calculated Formulas = 3072 Kb

Export = 1024 Mb ( is the maximun that the qvs let me set here)

Sort By Exp = 2048 Mb

Working Set = Low 70%, High 90%, Cache 10%

Object Calculation Time Limit = 36000

Max Symbols = 100

Allow document autoload = Checked

Max Num Concurrent Sessions = 5000

Possible session timeout = 3600

Max Inactive session timeout = 0

Mas Total session timeout = 0

And the DWORD ExportMemoryLimit = 20000 (decimal)

Thanks a lot again!

Gabriela

vgutkovsky
Master II
Master II

Hmm...maybe try adjusting the <QvsTimeout> in C:\ProgramData\QlikTech\QvWebServer\config.xml. Other than that, you registry value looks wrong; like I mentioned, it's in bytes.

Also, if you're using IIS, you might want to check the general IIS and ASP.NET timeouts.

Regards,

Not applicable
Author

Hi Gabriela,

I case of IE it is possible to export large file (i.e More than 65 K rows) as it will export in multiple sheets but in case of AJAX it is not possible to export the file more than 64999 rows.

Hope this helps you

Regards

Himanshu Sethi

suniljain
Master
Master

Dear Himanshu,

Pls try with QV 9 SR7 . because that bugs is removed in SR7.

Not applicable
Author

Thanks a lot Vlad, i´m going a try this options.... yes the value was wrong, i alredy change it.

Not applicable
Author

Gabriela,

Maybe you could generate a big database with txt or csv extension after the model is reloaded so if the user wants to use large extension of data he uses the database you generate.

Regards