Skip to main content
Announcements
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Migrate QVPR from 8.5 to 9.0

Hi all !

Does anybody know how to import a 8.5 QVPR into QV Publisher 9.0 ?

Thank You!

George Savu

1 Solution

Accepted Solutions
Not applicable
Author

Hi,

I have managed to get it to work. Te solution was to reinstal the OS.

Most likely the error was caused by having a QV Server 9.0 previously installed on that machine , and even if I have removed it somehow it musu have left some files behind that were preventing the 8.5 from working.

Txs

View solution in original post

7 Replies
Gustav_Guldberg
Employee
Employee

Hi George,

From the release notes:

"The Upgrade tool for upgrading your QVPR database is not run automatically after installing. You need to manually start it to upgrade your database before you can start using the software or create a new database."

The tool can be found here:
C:\Program Files\QlikView\Publisher\Command Center Service\PubUpgradeTool

You should be able to move the backup of the 8.5 QVPR to the following directory...
C:\Documents and Settings\All Users\Application Data\QlikTech\Publisher\CommandCenter
...and then runt the upgrade tool.

Regards,

Gustav

Not applicable
Author

Hi ,

This could be a good ideea unfortunatelly I can't test it.

I have Windows Server 2008 X64 , and a backup of a QVPR from 8.5, and if I try to install Qlikview Publisher 8.5 (SR5) I get the following error:

Failed to connect to command center at url: http://localhost:8081/qtcc.asmx.

This error might occur when having soap extensions enabled while running on a double byte language OS.
To disable soap extensions. Edit web.config and set EnableSoapExtensions to False

Extended technical information is:
Exception details


System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 127.0.0.1:8081 at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress) at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception) --- End of inner exception stack trace --- at System.Net.HttpWebRequest.GetRequestStream() at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at CPGlobal.CommandCenterWebService.CommandCenterWebService.CheckPrerequisites(String Cert) at CPGlobal.ExtendedAuthenticatedRole.AuthorizeMe()

Ideeas anybody ?

Txs.

Karl_Humma
Employee
Employee

If you see the above error in the XS log, it is most likely related to the XS service account not having the appropriate privileges to write to the c:\Windows\Temp directory etc, and you need to be sure the account can add, delete etc, which should allow the service to then start.
If the above is in place and correct, check to be sure the System Variables that point to the TEMP and TMP directories are setup and points to the directories you checked.
/Karl

Not applicable
Author

Normal 0 21 false false false RO X-NONE X-NONE MicrosoftInternetExplorer4

Hi Karl,

All of the above is set correctly. The user for XS is the Administrator and all path are correct.

I belive that the error is morelikely related to the OS wich is Windows Server 2008, and its specific version on IIS, any suggestions on that ?

Txs

Bill_Britt
Former Employee
Former Employee

If McAfee is on the machien you will have to change the ports, because it uses 8081. Here is how if you need it..

To change the port used by CommandCenter you need to make alterations to two files. This example changes from 8081 to 8084.

1. Open Web.Config (usually here:- C:\Program Files\QlikView\Publisher\ControlPanel ) and edit the following line:

in AppSettings

<add key="CommandCenterURL" value="http://localhost:8084/qtcc.asmx"/>

*** note the port has been changed to 8084 already ***

2. Open QVPublisherCommandCenterService.exe.config

found here:- C:\Program Files\QlikView\Publisher\CommandCenterService

edit AppSettings again

<add key="WebservicePort" value="8084"/>

Restart the Publisher services. Note you must use an unused port.

To test that it works open the Publisher control panel.

You can also test it by using this URL:

http://localhost:8084/qtcc.asmx?HelloWorld

Bill - Principal Technical Support Engineer at Qlik
To help users find verified answers, please don't forget to use the "Accept as Solution" button on any posts that helped you resolve your problem or question.
Not applicable
Author

Hi ,

It is not a McAfee issue , we don't use it, and anyhow we changed the port to no effect.

Txs

Not applicable
Author

Hi,

I have managed to get it to work. Te solution was to reinstal the OS.

Most likely the error was caused by having a QV Server 9.0 previously installed on that machine , and even if I have removed it somehow it musu have left some files behind that were preventing the 8.5 from working.

Txs