Qlik Community

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Announcements
Join “Do More With Qlik” with Mike Tarallo to get a first-hand look at the New Authoring Experience, June 29th: REGISTER HERE
cancel
Showing results for 
Search instead for 
Did you mean: 
ronald_gdi
Contributor III
Contributor III

Performance Qlikview Server SR7

In the last week the company installed the last version of Qlikview Serve (SR7) in new machine.

The machine is 2 processors Intel Xeon E7-4890 v2 and 1,00 TB (ram) and the Windows 2008 R2 SP1.

When we are in the ranges of peak usage (150 users) the application was slow and occur several errors in event viewer in the Qlikview WebServer Component.

The errors are below:

QvWebServer = Request failed: m_Comm.Receive() received zero bytes.

QvWebServer = Request failed: The communication with QlikView Server failed (TimedOut)!

The first error occur every five seconds.

Can anyone help me?

Thank you.

1 Solution

Accepted Solutions
Chris_Rice
Support
Support

It's actually set in the Settings.ini file:

The setting must be set in the Settings.ini file as a [Settings 7] entry:

  • EnableNumaRoundRobin=0

EnableNumaRoundRobin states since QV11.2 SR2

0 (default): Automated state where QlikView Server at startup detects whether NUMA is enabled or disabled at certain hardware and adapts to it. If NUMA is enabled QlikView Server will ignore NUMA nodes when allocating memory.

1: QlikView Server  is acting as if NUMA is enabled from BIOS (without any attempts to detect it)

2: QlikView Server will not ignore NUMA nodes if present (i.e. NUMA enabled)

The Settings.ini file can be found in the following location:

Windows Server 2003

C:\Document and Settings\All Users\Application Data\QlikTech\QlikViewServer

Windows Server 2008 and later

C:\ProgramData\QlikTech\QlikViewServer for Windows 2008 and later !

View solution in original post

7 Replies
Chris_Rice
Support
Support

This almost looks like a networking issue.  Is everything installed on one machine?  Are the QVWs hosted on that same machine?  Do you see any errors in the Events, Performance, or Sessions logs?

ronald_gdi
Contributor III
Contributor III
Author

Hello Chris,

I verified the server and didn't have occured errors.

The max of capacity usage was 40%, but in this scenario the application was slow.

I have a great doubts with a BIOS configuraration, because I read post that NUMA parameter is essencial to make performance, but this processor model has four kinds of configuration:

ONE (1-way)

ONE (2-way)

OFF (4-way)

OFF (8-way)

Qlik recommends NUMA OFF, but which one?

Thank you.

Kind regards

Chris_Rice
Support
Support

It's actually set in the Settings.ini file:

The setting must be set in the Settings.ini file as a [Settings 7] entry:

  • EnableNumaRoundRobin=0

EnableNumaRoundRobin states since QV11.2 SR2

0 (default): Automated state where QlikView Server at startup detects whether NUMA is enabled or disabled at certain hardware and adapts to it. If NUMA is enabled QlikView Server will ignore NUMA nodes when allocating memory.

1: QlikView Server  is acting as if NUMA is enabled from BIOS (without any attempts to detect it)

2: QlikView Server will not ignore NUMA nodes if present (i.e. NUMA enabled)

The Settings.ini file can be found in the following location:

Windows Server 2003

C:\Document and Settings\All Users\Application Data\QlikTech\QlikViewServer

Windows Server 2008 and later

C:\ProgramData\QlikTech\QlikViewServer for Windows 2008 and later !

ronald_gdi
Contributor III
Contributor III
Author

Wonder! Thank you very much.

I checked the parameterization of Qlikview and found this item in the archive.

I'll make the adjustment today and see the results, then you notice.

With this parameterization does not matter how the NUMA is configured in the BIOS?

Kind regards.

Chris_Rice
Support
Support

I believe that is correct.  This setting is for whether or not QV uses NUMA, I think.

ronald_gdi
Contributor III
Contributor III
Author

Marvelous.

We maded the changes and performance was very good!

Thank you very much. Now I alredy documented the tip.

Kind regards!

arish_delon
Creator
Creator

Hi Chris,

I do have the following entry "EnableNumaRoundRobin=0" in my Settings.ini located at C:\ProgramData\QlikTech\QlikViewServer.

But I still get the following error: Event ID 0: QvWebServer = Request failed: m_Comm.Receive() received zero bytes.

I am running 11.20 SR 12 on Windows 2008 R2

Regards

Arish