Skip to main content

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Announcements
On-Demand Webinar: Learn proven best practices for a smooth transition to Qlik Sense® SaaS. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
markwebb
Contributor II
Contributor II

QMC Task Hanging Indefinitely

I have a QMC task that runs every day and normally takes around 15 seconds to complete. Recently however it seems to hang every few days and doesn't complete until we cancel it.

It's a query running against a MYSQL database and we can see the query from the database, but there don't appear to be any rows being returned.

I had the same issue running the task directly on the Qlikview server so it doesn't appear to be an issue with QMC. When I copied the live qvw and tested in our development area it worked ok, so I removed the initial qvw and replaced with the development version which resolved the problem, but a week later it started the same behaviour. Has anyone else experienced this issue?

11 Replies
Chanty4u
MVP
MVP

HirisH_V7
Master
Master

Hi,

Check this way ,

  • Is there any conditional loops in your script.
  • Recent Server upgrades!
  • synthetic keys/loosely coupled tables

Qlikview task in QMC seems running forever

QMC: Task hangs

HTH,

Hirish

HirisH
“Aspire to Inspire before we Expire!”
markwebb
Contributor II
Contributor II
Author

Thanks for the reply. It doesn't sound like it's related to the second issue as everything works as expected in QMC other than the task hangs. I am also experiencing the same issue when running the qvw directly.

With regards to the first link, it sounds similar in some ways, but we are shortly having our server replaced so this may resolve if it is related.

markwebb
Contributor II
Contributor II
Author

Thanks for the reply. Its simply a sql query which then stores into a QVD so it doesn't fit two of those three suggestions. The server hasn't been upgraded so that should not be an issue.

janterje
Partner - Contributor II
Partner - Contributor II

Hi Mark,

If you have not already done so, I would start by looking in the log file of the qvw.

If you post the log, the community can take a look as well.

BR,

Jan Terje

markwebb
Contributor II
Contributor II
Author

Thanks Jan, unfortunately we don't store a history of the logs and its overwritten every day. Today the job ran ok but we'd already looked at the log and it looks exactly the same as when the job runs successfully. It is hanging when running a MySQL query and the log is simply waiting for a response.

janterje
Partner - Contributor II
Partner - Contributor II

Hi Mark,

I'm pretty confident that this is not a QlikView-issue, but either:

  1. A problem on the MySQL server.
    What does the logfiles on the MySQL server say when this problem occurs?
  2. A problem with the database driver on the QlikView server.
    Is it the same driver version on the delveloper and prod server?

BR,

Jan Terje

markwebb
Contributor II
Contributor II
Author

Thanks Jan,

I've had our DBA have a look at the query while its executing against the database and not returning any rows and there appears to be nothing unusual about it other than not returning any rows. If I copy the SQL and submit directly against the database it responds immediately.

The drivers seem fine as the jobs run with no issues most days, just occasionally they experience this issue, even when running directly on the qlikview server. Another resolution I've found is to 'reduce data' from the qvw and resubmit and this seems to resolve the issue.

There seems to be nothing I can pinpoint as a problem, but this is happening almost every day now on a different job.

Not applicable

Hello Mark,

What is the QMSChunkSize  set on your QVManagementService.exe.config file? This file is located under C:\Program Files\QlikView\Management Service. If it set to 100, change it to 50 and vice versa

Thanks

Chaitanya Somineni