Qlik Community

Ask a Question

QlikView Administration

Discussion Board for collaboration on QlikView Management.

On Demand Webinar: See Why Thousands of QlikView Users Have Switched to Qlik Sense. REGISTER
Showing results for 
Search instead for 
Did you mean: 
Not applicable

QMSEDX.exe Unhandled exception

Hi there.

We are using QMSEDX.exe to trigger document re-loads from an external scheduler.
Prior to our recent purchase of a Publisher licence we were directly triggering the .qvw document and things were working well.

Following the purchase of Publisher we are now triggering the task and have started to get unhandled exception errors returned from QMSEDX.exe.

Typically we are getting
"System.ServiceModel.FaultException: System.Exception: Could not find a result for the specified execution ID"
"System.ServiceModel.FaultException: Message inspection failed"

The task is triggered and runs to completion on the server but evidently with the above problem we are unable to see this from the result of the QMSEDX job.
We only have a single QlikView server and the QMSEDX job is running on the same server.
Server OS is Windows 2008 R2 SP1 with QlikView v11 SP1

QV Support are suggesting the problem is with QMSEDX.exe (possibly not "thread safe"??) and since it is not a supported utility are unable to help.

Has anyone else seen similar problems and does anyone have any ideas?

Typical output from the QMSEDX job below.

Any help gratefully received!

Successfully started task with id/name=OMP_SDWH_QVDs

Unhandled Exception: System.ServiceModel.FaultException: System.Exception: Could not find a result for the specified execution ID "d302bfec-f6c7-4232-866b-ed32ff2734ea"

Server stack trace:
   at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
   at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
   at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
   at QMSEDX.QMSAPI.IQMS.GetEDXTaskStatus(Guid qdsID, Guid executionID)
   at QMSEDX.QMSAPI.QMSClient.GetEDXTaskStatus(Guid qdsID, Guid executionID)
   at QMSEDX.Program.<>c__DisplayClasse.<PollSingleTask>b__d()
   at System.Threading.SpinWait.SpinUntil(Func`1 condition, Int32 millisecondsTimeout)
   at QMSEDX.Program.PollSingleTask(IQMS client, Guid execId, Int32 pollInterval, Int32 timeout)
   at QMSEDX.Program.TriggerAndMonitorTask()
   at QMSEDX.Program.Main(String[] args)

25 Replies
Not applicable

Looks as if nobody else has seen the problem or has any ideas!!

Maybe as more people start using the combination of QV11/QMSEDX it may also be seen elsewhere?


I am having the same trouble, as far as I can tell.

My scenario is that I try to trigger a reload of the QVW from the AJAX client (i.e. when the document has been been distributed to the Access Point). Running QMSEDX from the command line works fine, but when started from within a macro, which in turn is started by clicking a button in the web browser/AJAX client, I get the same error as you report.

Did you have any luck finding a solution?

Please mark the post as a solution if it provided you with a solution to the topic at hand. Thanks!
Not applicable

A while ago QV Support came back to me and said the problem may not be with qmsedx.exe after all and offered to help to find where the problem actually was.

They have not been able to reproduce the problem on their system and since then I have been helping out as much as I can since we are still getting the it.

So far no luck though in determining exactly what is going on.

Maybe worth you lodging a support call if for no other reason than to confirm that it is happeneing elsewhere!

Not applicable

Does you create task in QEMC ?

Can you start task manually from QEMC ?

Can't start task using QMSEDX from command console window ?

Publisher service account rights are enough to FileSystem?

QMSEDX is not succesfully on every task ?



I found the cause of my problem, it was due to a couple of the QV services running under different Windows accounts. After changing them over to use the same account things worked nicely.

There were some pretty obscure error messages though, not really indicating that this was the root cause of the problems.

Problem solved here though.


Please mark the post as a solution if it provided you with a solution to the topic at hand. Thanks!
Not applicable


Glad you got it sorted.

I checked and all our QV services are running under the same local user with admin rights so that isn't the problem here.

QMSEDX is also run under the same account.


Same issue here, most of the time it's working but also failling sometimes...

Not applicable

Hi, i'm having the same issue "sometimes". But my services are running under the same domain acount, whithin a clustred architecture.

Somebody has found a logical explanation for this problem??


Slight update:

I have patched QMSEDX.exe to add a simple "retry if it fails" in the PollSingleTask() function and it seems to work now but It has been in production for only one week so it may require some more time... It someone is interested I can attach the patched file.