Qlik Community

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Announcements
See why Qlik was recognized for the seventh year in a row – and discover how we can help you tackle your data integration challenges. Get the report
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

QV 11 - User Documents - can't remove qvw

Hi.

For some reason our QMC is still showing a User Document, that has been removed.

I have tried to re-create the a document with the same name, just to be sure that no Task or DocCal was allocated the document. And there is nothing of that kind assign to the document.

But after checking for all that and after deleting the qvw-document again, the document still shows under the User Document in the QMC.

Trying to apply some change to the document in User Document pane, I'm getting the error:

"Failed to set document meta data".

For some reason the document name is spelled with upper case (capital) letters in the QMC.

Any ideas how to remove that User Document from the QMC?

(It's not possible to remove the pgo-files, because they holds a lot of info on other documents).

1 Solution

Accepted Solutions
Not applicable
Author

Hi again.

Looking at the qlikview event-log it turned out, that qlikview for some reason had dobbled the path for the qvw-file in our NAS. That is: the qvw-file (the user document) was placed in:

\\nas1\gruppe\QlikView Storage prod\PUBLIC\QlikViewServer

but the event-log pointed at

\\nas1\gruppe\QlikView Storage prod\PUBLIC\QlikViewServer\nas1\gruppe\QlikView Storage prod\PUBLIC\QlikViewServer

After creating this path - and putting the a qvw in the folder with the relevant name, it was possible to delete a DocCal that was attached to the file. Deleting the qvw file again and the false dobble-path - this made the User Document disappear.

View solution in original post

13 Replies
Bill_Britt
Support
Support

The PGO files don't hold document information. That is stored in the .meta file. Make sure you remove the .meta and .share file for that document.

Bill

Bill - Principal Technical Support Engineer at Qlik
To help users find verified answers, please don't forget to use the "Accept as Solution" button on any posts that helped you resolve your problem or question.
Not applicable
Author

Hi Bill

Thanks - I did remove both meta og shared

fabienmd
Partner - Creator
Partner - Creator

Hi,

We have the same issue, a .qvw is in userdocument and we can't remove it.

Did you find a way to remove yours ?

Thanks

Not applicable
Author

Hi fabienmd

No - it's still there.

Not applicable
Author

Hi again.

Looking at the qlikview event-log it turned out, that qlikview for some reason had dobbled the path for the qvw-file in our NAS. That is: the qvw-file (the user document) was placed in:

\\nas1\gruppe\QlikView Storage prod\PUBLIC\QlikViewServer

but the event-log pointed at

\\nas1\gruppe\QlikView Storage prod\PUBLIC\QlikViewServer\nas1\gruppe\QlikView Storage prod\PUBLIC\QlikViewServer

After creating this path - and putting the a qvw in the folder with the relevant name, it was possible to delete a DocCal that was attached to the file. Deleting the qvw file again and the false dobble-path - this made the User Document disappear.

Not applicable
Author

Hi,

I have the same problem, but I can't create this path. According to the event log it points to

C:\ProgramData\QlikTech\Documents\E:\QLIKVIEW_ANWENDUNGEN\VERÖFFENTLICHTE DOKUMENTE\

and it's not possible to create a folder named "E:" ...

Where the QV-Server stores this information? Can I changed the path there?

Thanks

Not applicable
Author

where do you find the eventlog where this is written??

Not applicable
Author

I found it on the QV-Help:

The default location on Windows 2008 Server is

C:\Documents and Settings\All Users\Application Data\QlikTech\QlikViewServer

chall-usa
Contributor II
Contributor II

Did you find a solution to this problem? According to my event log my document is in D:\QlikviewDocs\D:\QlikviewDocs. I can't create a folder name "D:"

Thanks