Qlik Community

Ask a Question

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Announcements
On Demand Webinar: See Why Thousands of QlikView Users Have Switched to Qlik Sense. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
krishnamajhi
Contributor II
Contributor II

QlikView Scheduler task fails on Schedule but completed successfully on manual trigger from QMC

Hi Qlik Team,

Need you urgent help look into this.

The publisher task is running successfully when I run manually but as per schedule its failing.

We are using QlikView publisher to reload the QVWs. I have attached one success and failure case.

Let me if any further details required.

Regards,

Krishna 

Labels (1)
1 Solution

Accepted Solutions
krishnamajhi
Contributor II
Contributor II

Hi,

Yes, I still did not find how the task were completing successfully when I run them manually but the hourly schedules were failing. The Qlik is using one service account. I have monitored more than 2 hours many jobs were successful and few were failing with error message 'Error Document open call failed. The document might require username and password.".

Earlier today I found many more jobs were failing and few jobs still running successful.

I have verified the Service account is set not expire and its even not locked. So as solution available in community, I have reapplied existing service account password to the Five Qlik Services and restarted the services.  Also made sure the service account has full permission to all the source documents and reapplied ther permissions.  Which seems resolving the issue with out any failure.

Thank you, Krishna N Majhi

View solution in original post

4 Replies
rubenmarin

Hi, this usually is caused because the windows account that runs QlikView services lack of permission to access the document, in may be because it doesn't have access to an external drive or don't have write permission in a folder  where the qvds are stored.

In this case, as the log says "Error Document open call failed. The document might require username and password." seems the document has section access and the user running the service is not included so it can't open the document.

In case of using Qv users or any other cases you can include credentials in the reload task of the document, is at the bottom.

krishnamajhi
Contributor II
Contributor II

Hi,

Yes, I still did not find how the task were completing successfully when I run them manually but the hourly schedules were failing. The Qlik is using one service account. I have monitored more than 2 hours many jobs were successful and few were failing with error message 'Error Document open call failed. The document might require username and password.".

Earlier today I found many more jobs were failing and few jobs still running successful.

I have verified the Service account is set not expire and its even not locked. So as solution available in community, I have reapplied existing service account password to the Five Qlik Services and restarted the services.  Also made sure the service account has full permission to all the source documents and reapplied ther permissions.  Which seems resolving the issue with out any failure.

Thank you, Krishna N Majhi

View solution in original post

krishnamajhi
Contributor II
Contributor II

Hi,

We do use section access. The failed QVWs don't  use section access. 

Regards, Krishna  

Brett_Bleess
Support (Former)
Support (Former)

Krishna, have a look at the following Article when you can, might give you some further things to look into regarding your Publisher setup to ensure things are optimized etc.  The other thing that can cause those issues you were seeing is trying to run too many concurrent tasks without having adjusted the Desktop Memory Heap setting in the Windows Registry, so check that out too, it is in the attached .pdf in the Article.  Thanks for circling back and closing out your thread too, much appreciated!

Scaling QlikView Publisher 

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.