Skip to main content
Announcements
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

QlikView Web Ticket not passing User ID to QVW

I'm using the Webticket method of authenticating and section access for authorization (on QlikView Extranet Server).

I'm able to successfully generate a ticket and successfully log into the access point using the following call:


http://qvserver/QvAJAXZfc/Authenticate.aspx?type=html&webticket=niH06FElbrmGLxLFRXDXel44TNpUhGaQAZs0...


However, when I try to access a QVW with section access enabled, the user is then prompted for login credentials:

Screen Shot 2013-11-28 at 9.08.40 AM.png

It was my understanding that QV would pass the User ID of the logged in user to the QVW file.

I'm using DMS method of authentication and my users are stored in a table using ODBC.

How can I pass these credentials to the QVW from my PHP webticket script to avoid this? I've tried hard coding user credentials in both the PHP script that generates the ticket and the QVW load script.


I cant use NTNAME, as this is a public/customer-facing server - therefore the users can't be authenticated with NTNAME.


Can anyone help??

1 Solution

Accepted Solutions
Not applicable
Author

We are also using WebTicket with DMS. We have a table in a database and validate users from the login form.

Once validated the user, the form requests a ticket to a QlikView and passes this to the document.

In document are using ntname, follows

--------------------------------------------------------------------

Section Access;

LOAD UPPER (ACCESS) ACCESS AS,

UPPER (NTName) AS NTName

FROM

$ (v_QVDPropio_Path) \ USUARIOS.qvd (qvd);

Section Application;

---------------------------------------------------------------------

Use NTName and ACCESS fields.  These two data need to be accessed by WebTicket.

I hope my answer is helpful, but do not hesitate to contact me.

Good luck

Guillermo

View solution in original post

14 Replies
Not applicable
Author

Anyone ideas?? I've scoured every forum I can find for an answer, to no avail

Not applicable
Author

We are also using WebTicket with DMS. We have a table in a database and validate users from the login form.

Once validated the user, the form requests a ticket to a QlikView and passes this to the document.

In document are using ntname, follows

--------------------------------------------------------------------

Section Access;

LOAD UPPER (ACCESS) ACCESS AS,

UPPER (NTName) AS NTName

FROM

$ (v_QVDPropio_Path) \ USUARIOS.qvd (qvd);

Section Application;

---------------------------------------------------------------------

Use NTName and ACCESS fields.  These two data need to be accessed by WebTicket.

I hope my answer is helpful, but do not hesitate to contact me.

Good luck

Guillermo

jaimeaguilar
Partner - Specialist II
Partner - Specialist II

Hi,

I think that your case is a little bit different because of the extranet server, however I think you can still use NTNAME or USERID (you can use this if the NTNAME cause you conflict with the extranet server), just to passing this data to the webticket (Just like Guillermo Said). Besides if you don't want this double authentication (Webticket and then when you open the QVW), you can disable the field PASSWORD in section access.

This way, once webticket gets the NTNAME/USERID and ACCESS, then the document will open without asking again for credentials and displaying just the information that user is allowed to see,

regards

Not applicable
Author

Thanks for your responses guys, this is starting to make more sense!

This is my current section access script (will replace this with a SQL lookup in future):

Section Access;

LOAD * INLINE [

ACCESS, USERID, Customer_ID

ADMIN, ADMIN, *

USER, customer@email.com, 500475

USER, customer2@email.com, 153488

USER, customer3@email.com, 153489

];

So Guillermo, we should be using NTNAME? I believe that a domain needs to be prefixed on the NTNAME in section access - How should the NTNAME field be formatted?

Example:

Section Access;

LOAD * INLINE [

ACCESS, NTNAME, Customer_ID

ADMIN, ADMIN, *

USER, ???????\customer@email.com, 500475

USER, ???????\customer2@email.com, 153488

USER, ???????\customer3@email.com, 153489

];

Also, are the following settings correct for this method?

Auth.jpg

Not applicable
Author

NTNAME is the field name for QlikView, there you can store any data.

for example: JPerez or jperez@company.com

We have configured the Web Server as follows.

16-01-2014 08-48-23 p.m..png

We have a separate ISS Server.

Not applicable
Author

The change to NTNAME in section access solved my issue!

For future reference (for anyone else trying to work this out), the url I ended up using for accessing directly to a QVW after retrieving a web ticket:

http://<QVSERVER>/qvajaxzfc/authenticate.aspx?type=html&try=/qvajaxzfc/opendoc.htm?document=<QVWFILE.QVW>&host=QVS@<QVSERVER>&keep=true&back=Login.htm&webticket=<WEBTICKET>

I appreciate your help Guillermo and Jaime, thanks to you both!

Not applicable
Author

This is very helpful!

My question is, if you just use ACCESS and NTNAME in the section access, then how do you set up the reload on the server?  It asks for a username and password - it has to match an entry in section access.  A blank password worked before I changed to NTNAME, and I just put in ADMIN as the username.  But now it seems that I need the NTName of the account that will run the reload?  Is that correct?

Not applicable
Author

Hi,

I am having some issues when implementing Web Ticket. I am using membership database to authenticate user in My Web application. Then I am generating tickets and creating URL to redirect to my qlikview document. I need to know if need to change directory service connector to configurable ODBC to make it work.

Thanks.

Not applicable
Author

Hi Jon,

I am facing some issue while I am implementing WEbticket method to access Qlikview document..

Here is the details...

I have configured out QVWS as below:

Authentication: Always

Type: Ntlm

Login Address: Alternate Login page


I have below urls to access the document on the server...


Loadbalancer one is:

http://<serverip>/QvAJAXZfc/AccessPoint.aspx?open=&id=Customer%7CCUSTOMER%2FCUSTOMER_LERG.qvw&client=Aja

Actual one is:

http://<serverip>/QvAJAXZfc/opendoc.htm?document=CUSTOMER%2FCUSTOMER_LERG.qvw&host=Customer

I was succesfull getting the webticket form above  server, then I am trying to redirect to url as  you mentioned above..

Then I am getting just  "loading....... ", but it never completed loading the page , but when I saw the view source, I could see that all the html content..

Please could tell, am I missing something else.

Your help is really grateful to me and appreciated.

Thanks,