Skip to main content
Announcements
See what Drew Clarke has to say about the Qlik Talend Cloud launch! READ THE BLOG
cancel
Showing results for 
Search instead for 
Did you mean: 
Shalom_Daniel
Contributor II
Contributor II

Qlikview MACROS Error

Hi,

I am facing a macros issues sometimes which leads to the loss of license temporarily in server, but after restarting the server it works fine. Can anyone help me in this also please find the screenshot below for the error.

Shalom_Daniel_0-1670217711078.png

Labels (1)
2 Solutions

Accepted Solutions
Bill_Britt
Former Employee
Former Employee

This could be an issue with the QVS settingws.ini file. When you click on " OK" above, it writes an Hash to the file.

If you don't have a lot of mount folders, you could stop the QVS service delete the settings.ini, restart service and setup the QVS again with license.

Bill - Principal Technical Support Engineer at Qlik
To help users find verified answers, please don't forget to use the "Accept as Solution" button on any posts that helped you resolve your problem or question.

View solution in original post

Chip_Matejowsky
Support
Support

Hi @Shalom_Daniel,

What version of QV Desktop & QV Server are you running? By "leads to the loss of license temporarily in server" are you referring to QV Desktop on the QVS server  reverting to Personal Edition? If so, then I agree with @Bill_Britt in that something is likely causing access issues to or overwriting the %Users%\<your username>\AppData\Roaming\QlikTech\QlikView\Settings.ini file.  Is this location excluded from virus scanning or any other software that scans files in real time?

 

Best Regards

Principal Technical Support Engineer with Qlik Support
Help users find answers! Don't forget to mark a solution that worked for you!

View solution in original post

3 Replies
Bill_Britt
Former Employee
Former Employee

This could be an issue with the QVS settingws.ini file. When you click on " OK" above, it writes an Hash to the file.

If you don't have a lot of mount folders, you could stop the QVS service delete the settings.ini, restart service and setup the QVS again with license.

Bill - Principal Technical Support Engineer at Qlik
To help users find verified answers, please don't forget to use the "Accept as Solution" button on any posts that helped you resolve your problem or question.
Chip_Matejowsky
Support
Support

Hi @Shalom_Daniel,

What version of QV Desktop & QV Server are you running? By "leads to the loss of license temporarily in server" are you referring to QV Desktop on the QVS server  reverting to Personal Edition? If so, then I agree with @Bill_Britt in that something is likely causing access issues to or overwriting the %Users%\<your username>\AppData\Roaming\QlikTech\QlikView\Settings.ini file.  Is this location excluded from virus scanning or any other software that scans files in real time?

 

Best Regards

Principal Technical Support Engineer with Qlik Support
Help users find answers! Don't forget to mark a solution that worked for you!
Shalom_Daniel
Contributor II
Contributor II
Author

Hi ,

Thank you so much for the response, we have two server one is production server and another is development server. However development server have only Qlikview Desktop installed (Version : 12.6) and no services .

The mentioned issue is  occurring in the development server where there is only Qlikview Desktop installed.

Could you please provide any solution as this is becoming a major issue.