Qlik Community

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Announcements
Coming Aug. 9: New Simplified Authoring for Qlik Sense SaaS – For Details, CLICK HERE
cancel
Showing results for 
Search instead for 
Did you mean: 
shaosiong
Partner - Contributor II
Partner - Contributor II

Qlikview Management Console

Hi Qlik Heroes,

Some of my scheduled tasks in QMC are not loading even after it has passed that timing. When I manually tried to run it, there was a brief pause and the status went back to the same as if nothing has happened. I went into editing the task to check what is wrong and the following message appears.

shaosiong_1-1653667518412.png

 

Why is this happening and how can I rectify this?

Many thanks in advance!!!

 

 

Labels (1)
1 Solution

Accepted Solutions
marcus_sommer
MVP & Luminary
MVP & Luminary

The error-message says quite clear that the services-communication between the services is broken.

In my experience this happens often if the server-resources were overloaded. A single hit may enough that any of the services-communication failed - maybe it's just a timeout - and it won't be repaired in any way. The only solution is a re-start of the services but mostly better of the entire machine (on the OS side may also strange occurrences happens). Only errors which remain after a re-start are worth to be investigated but not any temporary stuff.

To keep your environment stable you need to ensure that such an overload is never possible. For this you need to size the working set settings and other performance settings in regard to your available hardware-resources and of course in regard to the number of parallel tasks and users.

- Marcus

View solution in original post

5 Replies
Jill_Masinde
Support
Support

Hello

The link below shows all services when running Qlikview Server with or without Publisher.

https://help.qlik.com/en-US/qlikview/May2021/Subsystems/QMC/Content/QV_QMC/QMC_Status_Services.htm

To verify all services are up and running go to QMC>Status>Services.  If any service is not running you can restart from the windows applet.  You may restart the Qlikview Distribution Service service and Qlikview Management Service at the minimum.

I hope this helps,

 

Chip_Matejowsky
Support
Support

Hi @shaosiong,

In addition to Jill's comment review the QlikView Management Service (QMS) log for errors and warnings.  Whenever you come across a warning or error in the QMC, this is the first log to check.  The default location of the QMS log is %ProgramData%\\QlikTech\ManagementService\Log and has a naming convention of YYYYMMDD.txt.  Post back here with what you find if you need further assistance.

 

Best Regards

Sr. Technical Support Engineer with Qlik Support
Help users find answers! Don't forget to mark a solution that worked for you!
shaosiong
Partner - Contributor II
Partner - Contributor II
Author

Thanks @Chip_Matejowsky  and @Jill_Masinde  for your feedbacks.

But I was curious about what the message from the QMC means cause I can't find any clues to it on google or the support site. Not sure if it is because my server is overloaded which it has always been when multiple users logged in. When I skipped to the Services in QMC nothing shows up as well. The logs are outdated to the last successful refresh date only. I have tried running the app but it is not responding at all.

Luckily the issue is fixed for now. Not sure if it is because the server has spaces freed up or cause something was done by another admin whom I am not sure who or how they did it.

Chip_Matejowsky
Support
Support

@shaosiong,

I'm glad to learn your issue is now fixed.  I can't really speculate on the issue without reviewing QMS logs first. If the QMS logs aren't showing the correct date, then you may not be looking in the correct location.  For QMS logs, the default location is %ProgramData%\QlikTech\ManagementService\Log on the server where the QMS is installed. 

 

Best Regards

Sr. Technical Support Engineer with Qlik Support
Help users find answers! Don't forget to mark a solution that worked for you!
marcus_sommer
MVP & Luminary
MVP & Luminary

The error-message says quite clear that the services-communication between the services is broken.

In my experience this happens often if the server-resources were overloaded. A single hit may enough that any of the services-communication failed - maybe it's just a timeout - and it won't be repaired in any way. The only solution is a re-start of the services but mostly better of the entire machine (on the OS side may also strange occurrences happens). Only errors which remain after a re-start are worth to be investigated but not any temporary stuff.

To keep your environment stable you need to ensure that such an overload is never possible. For this you need to size the working set settings and other performance settings in regard to your available hardware-resources and of course in regard to the number of parallel tasks and users.

- Marcus