Skip to main content
Announcements
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
cancel
Showing results for 
Search instead for 
Did you mean: 
jduarte12
Partner - Creator II
Partner - Creator II

Qlikview Server - How to remove AJAX toolbar and color background?

Good afternoon,

We are using QlikView Server 11 on Windows Server 2008 R2. As a development of our project, it is wanted that our dashboards don't present the AJAX toolbar when they are accessed via Internet Explorer or Google Chrome. It is also required that the dashboard background is white instead of the light grey thar appears by default.

Concerning that, I have read some topics on 'how to hide AJAX toolbar' or 'how to change the background color' and then some problems arise.

1- About hiding the AJAX toolbar, there are two options: on one hand by using the nobar.qar extension or, on the other hand, by modifying the opendoc.htm file in the \Qlikview\Server\Qlikview Clients\Qlikview Ajax folder. However, I installed the referred document extension but nothing changed. I also tried changing the opendoc.htm file by inserting

<style>

.QvToolbar

{

display:none;

}

</style>

between the head and body of the htm file, as I read in a QlikCommunity discussion.

The problem is that in the end none of those solutions produced the intended result: not having the AJAX toolbar in the web view of the dashboard.

I appreciate your help on realizing if either I had done something wrong or missed some step.

2- In order to change the dashboard's background color from light grey to white, it was recommended that the default.css file was modified. Thus, I would like to understand which changes should I make in the default.css.

I hope you can help with these two issues.

Thank you in advance,

João Duarte

Labels (1)
1 Solution

Accepted Solutions
Bill_Britt
Former Employee
Former Employee

Hi Joao,

I had issues with the extension also at first. My problem was the way I was appling it to the server. You need to install on the client machine and then move the folder over to the server location.

Bill

Bill - Principal Technical Support Engineer at Qlik
To help users find verified answers, please don't forget to use the "Accept as Solution" button on any posts that helped you resolve your problem or question.

View solution in original post

10 Replies
rwunderlich
Partner Ambassador/MVP
Partner Ambassador/MVP

I'm not sure about your toolbar problem. But re the background color, can't you just change it in the qvw?

-Rob

jduarte12
Partner - Creator II
Partner - Creator II
Author

Thank you very much, Rob.

I guess I got confused somewhere, for the background color was really easy to change in the "Document Properties" menu.

However, I will continue trying to understand how to solve the AJAX toolbar issue.

Best regards,

João Duarte

Not applicable

Hi, 

To hide the toolbar, try adding the following line to QlikViewAjax/htc/default.css: 

.QvAjaxToolbar { display:none !important; } 

Thanks,  Michael

Message was edited by: mgriffiths - fixed formatting

jduarte12
Partner - Creator II
Partner - Creator II
Author

Thanks, mgriffiths

However, the Ajax toolbar keeps appearing. Should I add that line in any specific part of the default.css?

Best regards,

João Duarte

Not applicable

As the last line should work. Make sure you've cleared your web browser's cache, since it may still be using the old version of the file otherwise.

Thanks,

Michael

jduarte12
Partner - Creator II
Partner - Creator II
Author

Even with cleared cache and placing the instruction at the last line, the bar remains there.

Thanks,

João Duarte

jduarte12
Partner - Creator II
Partner - Creator II
Author

Good afternoon,

In what concerns removing the AJAX toolbar, I tried both the document extension and editing de opnedoc.htm file again. The toolbar is still there, no matter what have been done (note that I clean regularly my browser's cache in order to avoid using previous versions of the file).

Have you got any ideas on how to solve this issue?

Despite believing it is not the case, I might be doing something wrong ou perhaps missing some step... Anyway, I have no ideia where.

Thanks in advance,

João Duarte

Bill_Britt
Former Employee
Former Employee

Hi Joao,

I had issues with the extension also at first. My problem was the way I was appling it to the server. You need to install on the client machine and then move the folder over to the server location.

Bill

Bill - Principal Technical Support Engineer at Qlik
To help users find verified answers, please don't forget to use the "Accept as Solution" button on any posts that helped you resolve your problem or question.
jduarte12
Partner - Creator II
Partner - Creator II
Author

Thank you, Bill

In the last week, there were other issues not related with QlikView that I had to take care of.

Back to the Ajax toolbar problem, I believe I understood your point. So, after uninstalling the nobar extension, I installed it again, this time assuring that it was firstly installed in the Client (C:\Users|[user]\AppData\Local\Qliktech\Qlikview\Extension\Document) and only then in the Server (C:\Program Data\Qliktech\Qlikview Server\Extension\Document).

After that, I opened some .qvw files and, under "Settings -> Document Properties -> Extensions", I activated the nobar extension.

I was expecting that when I entered the website where those .qvw are shown, the toolbar had disappeared. However, it is still there - for files with "hide tabrow" option activated or not.

Best regards.