Skip to main content
Announcements
The way to achieve your own success is the willingness to help somebody else. Go for it!
cancel
Showing results for 
Search instead for 
Did you mean: 
Anonymous
Not applicable

Qlikview server won't load a document with Section Access

Hi - We are relatively new to QlikView. After a few months evaluating and prototyping, we are trying to load an application using QlikView server within IIS. We have the Small Business Edition (v11) without Publisher and are using Active Directory authentication.

This all works very well, so long as we don't have Section Access and a hidden script. Obviously we would like to take advantage of data restriction techniques. These work fine on the desktop without NTNAME, but with named users (using USER and PASSWORD).

Before we externalise the security tables / files for scripting, we are testing Section Access using inline tables on the Server. Whenever we do this, it fails with the following message:

     "the document might require username and password"

We have done the following:

- Created a task to reload the document, and assigned the administrator user (called 'jdeadmin') to it

- We have tried ourdomain\jdeadmin, with actual password, the same user in upper case, a combination with the password of the hidden script, with and without domain.

- I have added the user to the Section Access as follows:

Section Access;

LOAD * INLINE [

ACCESS, NTNAME, COMPGROUP

ADMIN, OURDOMAIN\JDEADMIN

ADMIN, OURDOMAIN\IANS

USER, OURDOMAIN\YVONNEP, DIRECT

];

I don't want to name a user and password, we would like to stick with NTNAME.

Is there anything obvious we are doing wrong? Any help would be much appreciated.

Thank you in advance

Ian

12 Replies
kaushiknsolanki
Partner Ambassador/MVP
Partner Ambassador/MVP

Dear Ian,

     With section access report(application) to be reload from server, you need to pass the Admin user name which you had defined under the application as Admin and his/her password.

     This setting is avaiable under the reload tab.

     The password is needed for QlikView to authenticate the user for reloading the report.

Regards,

kaushik Solanki

Regards,
Kaushik
If reply is satisfactory, please "Like" the post.
If reply is solution, please mark as "Correct".
Anonymous
Not applicable
Author

Hello

Thanks for your reply. We have already done as you suggested, but we can try again. Does it need the domain name in front of it?

Thanks

Ian

Bill_Britt
Support
Support

If you are using server reloads you have to have the service account that QVS is running in Section Access as an ADMIN.

Bill

Bill - Principal Technical Support Engineer at Qlik
To help users find verified answers, please don't forget to use the "Accept as Solution" button on any posts that helped you resolve your problem or question.
Anonymous
Not applicable
Author

Thank you. I believe it is an Administrator, but do you mean a wide-ranging Domain administrator?

Bill_Britt
Support
Support

I am talking about the account that QVS is running under. If you look in services you will see the Qlikview services. To the right you will see the Log On As column and a user name. In the below picture you will see it listed as qvpub. qvpub has to be in section access as an admin

QV9-2013-03-14-10-44-58.png

Bill

Bill - Principal Technical Support Engineer at Qlik
To help users find verified answers, please don't forget to use the "Accept as Solution" button on any posts that helped you resolve your problem or question.
Anonymous
Not applicable
Author

Thanks Bill, here is the full run-down:

- We have the same user running the services as the reload (see screen shots)

- The user is also named within our (test phase) Section Access hidden script

- The user is however a local administrator of the server only. That appears to be fine, or at least up till now.

Does it have to be a domain administrator? If so, that would cause us significant problems as we will never be given such a powerful password and will need to rely on a separate group of people to set each of these up.

Here are our services:

Services.PNG

Here is the reload:

Reload.png

There is a password provided, too.

We've actually just noticed it has generated Windows event errors:

WindowsEvents.png

Of which the detail is:

EventDetail.png

Presuming we have the right user and password entered, does this mean a lack of permission, I wonder?

Thanks

Ian

sanketkhunte
Creator II
Creator II

Kaushik..

Thank you for your Reply.

We need to provide User Name and Password while Section Acess with simple UserID and Password.

Please tell me what will be the UserID and Password while Section Acess with NT Names.

Suppose we have

USER ID - sanket

password - sanket

NT Name - QV\sanket

when simple userid and password its simple

USER ID - sanket

password - sanket

please tell me while we are implementing NT Name.

Do we required to provide NT Name.

Bill_Britt
Support
Support

This is a very common problem. Your AD is not setup for anonymous query. The one solution is to use a Domain account and just make them a local Administrator on the local machine. If you do this don't forget to add the account to the QlikView Administrator Group..

Bill

Bill - Principal Technical Support Engineer at Qlik
To help users find verified answers, please don't forget to use the "Accept as Solution" button on any posts that helped you resolve your problem or question.
sanketkhunte
Creator II
Creator II

Thank you Bill !!

Let me try this one.