Skip to main content

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Announcements
CUSTOMERS ONLY: Now accepting customer applications for the 2023 Luminary Program: SUBMIT NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
luciancostin
Contributor III
Contributor III

Reset Macro security settings

Hello community,

Please help with the following problem:

- the same Qlikview application, opened with the Internet Explorer Plugin, on two machines with similar settings (similar user rights, similar programs), both having Powerpoint installed,

- a Macro which opens Powerpoint and dumps images,

works on one machine, opens it and starts dumping the images,

the other fails with error message: failed to create Activex object, error in Macro.

We understood it is a problem with the Macro Level settings, and so we have removed the lines with [Module Checksums System] from the file: C:\Users\%USERNAME%\AppData\Roaming\QlikTech\QlikView\Settings.ini  , as we read here: How to reset Macro authorizations

and here: QlikView macro security .

However, this does not seem to have any effect, the Macro still fails as described.

What are we doing wrong, what else should we change?

IE is 11, Qlikview version is 12.0...

13 Replies
marcus_sommer
MVP & Luminary
MVP & Luminary

Beside the macro-settings in QlikView there are also the IE respectively the Windows settings for the user important, for example the protected mode within the IE (disable it) or the various security settings to ActiveX (often it's enough to put the access point to the trusted sites instead of adjusting a lot of settings).

- Marcus

luciancostin
Contributor III
Contributor III
Author

The first problem is that i can't get the Macro Security pop-up to open , even after deleting the settings as said.

Opening the application on the same machine, but with a different user level (i.e.: admin), this immediately opened the security pop-up, and, after allowing system access, worked as expected.

We also tried pressing CTRL + SHIFT + M and this does not bring up any windows/pop-ups.

marcus_sommer
MVP & Luminary
MVP & Luminary

I could imagine that this popup is just blocked through the above mentioned security settings - therefore check these first.

- Marcus

luciancostin
Contributor III
Contributor III
Author

The security settings are similar. We've gone through them one by one, on the two differently behaving machines.

luciancostin
Contributor III
Contributor III
Author

Please, anybody, any other ideas?

We have checked the ActiveX settings one by one, they are the same.

We've changed and even removed completely the Settings.ini file, no changes.

On the same machine, opening IE with a different user (admin), the settings open and Macro runs correctly to the end.

IE plugin has even been reinstalled.

The interesting part is that the menu Items: User preferences, document support info do not open, but only the 'about qlikview' pop-up opens.

Pressing CTRL+SHIFT+M on the machine does not work, it does not bring up any pop-ups.

marcus_sommer
MVP & Luminary
MVP & Luminary

This means it's depending to the user-profile. Anywhere the ActiveX is blocked. Beside the IE settings this could be also related to the various security settings of MS Office which may prohibit any outside-access on the office-tools.

- Marcus

luciancostin
Contributor III
Contributor III
Author

Dear Marcus,

We have checked the ActiveX Internet Explorer settings with the local IT . Pressing CTRL + SHIFT + M on the application does not show any pop-ups, what does this indicate? cannot have anything to do with MS Office. I'll play with my ActiveX settings and disable them one by one to see if i can get this same behavior.

marcus_sommer
MVP & Luminary
MVP & Luminary

It may sound a bit silly but have you checked if this popup window is hidden below another window or moved over the border of the screen or maybe displayed on a second (currenty not available) monitor?

- Marcus

luciancostin
Contributor III
Contributor III
Author

I kind of thought about it, but no.. that's not the case.. normally if the dialog opens up, then the actual screen is unclickable, which is not the case.

I've tried each and every one of the activex settings, changed their value, restarted, and opened again, without any effect. turned smart screen filtering on /off, checked firewall, without any success. Menu -> user preferences still does not open , document support info still does not open.. but intrestingly: About Qlikview opens, i can right-click the icon, as described in another topic i read here, and i can edit the settings from there.. i wonder how this pop-up opens and the other don't? Do you have any suggestions, what settings to change in order to get some debugging info?

i've checked firewall, antivirus, there is nothing in the logs, quarantine, or anything blocked.

Anyone, any hints? Am desperate!