Qlik Community

Ask a Question

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Announcements
QlikView forum consolidation is complete. Labels are now required. LEARN ABOUT LABELS
cancel
Showing results for 
Search instead for 
Did you mean: 
bcraymond
Partner
Partner

Send to Excel Issues for Some Users after Server Upgrade

Since upgrading the server to 12.4 some users are experiencing issues with Send to Excel. The user clicks the icon for Send to Excel and nothing happens. It seems like the pop up that asks if you want to open or save is being blocked.  Has anyone else experienced this?

Labels (2)
1 Solution

Accepted Solutions
Brett_Bleess
Support (Former)
Support (Former)

If you are using Ajax client, try clearing your browser cache, I think that may address the issue, sometimes after upgrades you need to do this to get everything working properly.

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.

View solution in original post

9 Replies
Chip_Matejowsky
Support
Support

@bcraymond ,

What was the previous build version prior to the upgrade to 12.40?

Are you seeing any XlsxExport errors in the QlikView Server Events log? If yes, can you post the exact error(s) to this thread?

Is the object users attempting to export to Excel large? If yes, then have a look at the Qlik Support article "Unable To Export Large Objects To Excel After Upgrading to November 2017" to ensure the appropriate configuration has been implemented in the QlikView Server settings.ini file.

 

Best Regards,

Chip

Sr. Technical Support Engineer with Qlik Support
bcraymond
Partner
Partner

We upgraded from v 12.04 to 12.40  There are no .xls errors I am seeing. The export size isnt large, I tried with only a few rows  and same issue exists.   The only errors i see around the time of the issue is below and I'm not sure it is related..

Failed to create QlikView Engine.. Exception=System.Runtime.InteropServices.COMException (0x80080005): Retrieving the COM class factory for component with CLSID {BE1F19B5-415E-11D1-934D-0040333C91CC} failed due to the following error: 80080005 Server execution failed (Exception from HRESULT: 0x80080005 (CO_E_SERVER_EXEC_FAILURE)). || at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandleInternal& ctor, Boolean& bNeedSecurityCheck) || at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark) || at System.Activator.CreateInstance(Type type, Boolean nonPublic) || at System.Activator.CreateInstance(Type type) || at QVBWrapper.Document.<CreateQVBProcess>b__123_0(Boolean mutexCreated) || at SolutionGlobal.GlobalMutex.Lock(Action`1 action, TimeSpan timeout) || at QVBWrapper.Document.CreateQVBProcess(ILogBucket logBucket, Boolean createEmptyDoc)

Chip_Matejowsky
Support
Support

Seems odd that you aren't seeing any errors in the QVS Events log, as the issue you described would definitely be an Engine issue. Is it possible to attach the most recent iteration of the QVS Events log when the issue occurred to this thread?

When the issue occurs are you noticing greater memory usage as reflected in the QVS Performance log? You may need to set the frequency of the Performance logging frequency down to 1 or 2 minutes from the default value of 5 in order to see a discrepancy.

What is the architecture of the environment - A single server with all QV services installed? A multi-node cluster with QV services dispersed across multiple servers?

The error you referenced looks to be from the QlikView Distribution Service (QDS) and wouldn't be related to attempting to export an object to Excel. Specifically to an issue where there are too many concurrent QDS tasks than there are available Max number of simultaneous QlikView engines for distribution as configured in QMC > System > Setup > QlikView Distribution Service > @QDS > Advanced tab.

Sr. Technical Support Engineer with Qlik Support
bcraymond
Partner
Partner

Attached event log from the time the user tried to send to excel. I think the issue is with the new browser window not appearing, rather than the 'send to excel' not working. But the users are on the same version of IE (11.0.96)   as I am and I'm not having the issue.  

bcraymond
Partner
Partner

sorry - to answer your other questions, we have single server with all services installed. No large memory increases when the issue happens. 

Bill_Britt
Support
Support

Hi,

The error message you posted above, looks more like a Tasklog error.  When you say Click a button, what have you got setup for the action? Is it macro code?

 

Bill

Bill - Designated Support Engineer at Qlik
To help users find verified answers, please don't forget to use the "Accept as Solution" button on any posts that helped you resolve your problem or question.
bcraymond
Partner
Partner

I am using the standard Send To excel check box option on the Caption tab in the chart properties , no macros. This issue doesn't happen for everyone, I have no issue when sending to excel. My event log entries look exactly the same as the users having issues.  

 

Brett_Bleess
Support (Former)
Support (Former)

If you are using Ajax client, try clearing your browser cache, I think that may address the issue, sometimes after upgrades you need to do this to get everything working properly.

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.

View solution in original post

bcraymond
Partner
Partner

Turns out this was the problem. Users had to clear the browser cache and it worked fine.