Qlik Community

Ask a Question

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Announcements
Our next Qlik Insider session will cover new key capabilities. Join us August 11th REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
oscarmqz
Creator III
Creator III

Test section access in desktop?

Is it possible to test section access code in desktop? I'm not the admin of the server and sometimes it's very annoying asking It to reload for every change I do I'd like to be able to try it in desktop but doesn't seem to be working...

Here's what I have

SECTION ACCESS;

LOAD upper(ACCESS) as ACCESS,

     upper(NTNAME) as NTNAME,

     upper(REGION) as REGION

FROM

[http://XXXXXXXXXXXXXXXXXXX/teams/QlikViewSCO/Repository/360Dashboard/SMCWQVData.xlsx]

(ooxml, embedded labels, table is AL);

and in the xlsx file:

ACCESSNTNAMEREGION
adminamericas\marquoscAMS

But I'm able to see all data...

Thanks in advance for your help!

1 Solution

Accepted Solutions
Nicole-Smith

Also, if you want the data reduced, make sure to have this option checked:

View solution in original post

7 Replies
Nicole-Smith

It is possible to test out section access in QV desktop.  Once you reload the dashboard, you need to close QV completely, then reopen the dashboard.  It should prompt you for credentials.  Be careful though, because if your section access code is bad, you could end up locking yourself out of the dashboard and losing any unsaved work!

Nicole-Smith

Also, if you want the data reduced, make sure to have this option checked:

View solution in original post

mov
Champion III
Champion III

Yes, it is possible.  In any case, since you're using NTNAME, you only can login as yourself.

Possible reasons that you see all data:
- "Initial Data Reduction Based on Section Access" is not checked.

- It is checked, but "Strict Exclusion" is not checked and region AMS doesn't exist.

I always recommend to use  "Initial Selection Based on Section Access" instead of Data Reduction for testing purposes - you can see what Section Access is doing.  When you know it works, switch to Data Reduction.

Regards,

Michael

oscarmqz
Creator III
Creator III
Author

Thanks Mike and Nichole,

     I've applied some changes as suggested, but now I see nothing

There is a Region called AMS, not sure if the data model has something to do?

I tried both options initial selection and initial data reduction, same result.

QVDB.png

Alejandro_Hernández

try renaming the Region field from your Regions table to uppercase. for example

Regions:

Load

Region as REGION

etc.

oscarmqz
Creator III
Creator III
Author

Just tried it, same result

oscarmqz
Creator III
Creator III
Author

It is working now... turns out I forgot to include this line at the end of section access statement:

Section Application;

And I did have to rename the field name to uppercase in order for it to work.

Region as REGION.

Thanks everyone!