Skip to main content

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Announcements
Welcome to Qlik Community! Check out our new navigation! FIND OUT MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
rennesia
Contributor III
Contributor III

V12.10 and queued reload

Since upgrading from QlikView V12.0 to V12.10 almost every reload results in a queued status. Before upgrading, everything worked fine.

Is there a solution for this problem?

12 Replies
its_anandrjs

Please check the logs for the better ways.

Regards

Anand

rennesia
Contributor III
Contributor III
Author

Attached you find (a part of) the performance log. In line 93 the server is restarted after upgrading to V12.10.
May be there is a designation to the cause of the queue in this file...

Not applicable

Does it stay in Queued state (then it indicates your system is overloaded) or is it just temporary until it enters Running state (then by design - a side-effect of the new load balancing feature)?

Have you enabled the load balancing feature?

rennesia
Contributor III
Contributor III
Author

It stays in queued state continuously. After disable, enable and run a manual reload of document it comes directly in the queued state. The load balancing feature was not enabled.

I discussed this problem with our Qlik sales agent. He advised me to uninstall V12.10 and continue with V12.0SR5. At the moment I am busy with uninstalling and installing...
Thanks for your help Magnus!

fjn
Employee
Employee

On previous versions of QlikView “running” state included both tasks running and tasks that should start but couldn't due to overloaded system.

In QV12.10, tasks that cannot start due to overloaded system will be shown as “queued”, which will indicate that the system is overloaded.

Are you sure that your system was not overloaded? Long running tasks, many tasks, etc.

Have you been in contact with Qlik support regarding this problem?

/Fredrik

Peter_Cammaert
Partner - Champion III
Partner - Champion III

Ah, so the 'Queued' state appears when no free Reload Engine is available to launch the reload? Nice visual modification !

Not applicable

If you system is overloaded you should this in the LoadBalancer_[DATE].txt log file. Check for a row like this:

"The system is currently overloaded."

When not overloaded anymore, you should see "The system is not overloaded anymore." (this might take one minute until this is logged).

pauljohansson
Creator III
Creator III

Peter cammaert - hopefully not only visual.

To allow tasks to be  queued rather than keep on trying getting a engine when there is non should be helpful in high load scenarios, at least, this is my hope. Can anyone confirm?

thanks in advance,

br

Paul

sarahallen1
Creator II
Creator II

When we upgraded to v12.1 we noticed this, and realised that the setting for 'max concurrent reloads' had been reset to 1.  We changed it back to 10 which was fine performance wise.

Might not be your issue though!