Qlik Community

Ask a Question

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Announcements
Join this live chat April 6, 10AM EST - QlikView to Qlik Sense REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Vengatesh
Partner
Partner

Wrong Report Distribution

Hi all,

I have dashboard with Five reports. I have created separate task for each report. Two reports (Report1 & Report2)are distributed without any reduction. While other three reports have reduction based on some fields. Among those Report3 is based on region which is working fine.

But the other two reports (Report4 & Report5) have to reduced based on area field. But the contents inside the reports are different. My problem is, I have created two separate tasks for each report with area as reduction field with respective report names. but both tasks are distributing same report which is Report5. even the Report4 task is distributing Report5. I want to distribute Report4 to different users and report5 to different users but both with area as reduction field.

PS: I have checked in Distribution -> File Type. Both task have two different reports. I tried renaming the reports but no use. I tried recreating tasks once again but no use.

Please Help.

You Know What To Do.
1 Solution

Accepted Solutions
Vengatesh
Partner
Partner
Author

Hi, Sorry for the dealyed response

Created two fresh reports, seems to work fine.

I suspect the issue might be, I Renamed the new Report with Old name and Old Report with new name.

You Know What To Do.

View solution in original post

5 Replies
Brett_Bleess
Support (Former)
Support (Former)

Likely going to need screenshot of the Reduce tab settings for the tasks in question in order to try to help.  Be sure to label things accordingly, so we can tell what is what.  I do have some other questions too, are you also doing a dynamic distribution, or static, as that is also an important thing in this case.  Sorry I cannot offer anything else, really need to see the configuration, as there are too many variables to guess as to what you may have done wrong here....

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
Arthur_Fong
Partner
Partner

Can you try separating the dashboard into 2?

One for distributing report4 to user group A.

The other to distribute report5 to user group B.

I think Section Access has restricted report distribution to work accordingly.

 

Vengatesh
Partner
Partner
Author

Hi @Brett_Bleess ,

Please find attached Screen shots.

Both CM Code and TM Code are same only. i have used alias name to differentiate them. but Report Banca CM wise and TM wise are totally different. But both tasks are distributing TM Wise report only.

I dont know what i am doing wrong here, it seems to work fine in other application reduce task.

Otherwise I have to try to create separate application for that report like @Arthur_Fong  mentioned. and there is no section access

You Know What To Do.
Brett_Bleess
Support (Former)
Support (Former)

Do you have anything configured in the Loop Field in Document menu settings on either task?  That is the other key thing here along with what Arthur mentioned too, in that having Section Access in play along with attempting to do Loop and Reduce/Distribute is not something that is recommended, as it can lead to unexpected results...

https://help.qlik.com/en-US/qlikview/April2019/Subsystems/QMC/Content/QV_QMC/QMC_Documents_SourceDoc...

https://help.qlik.com/en-US/qlikview/April2019/Subsystems/QMC/Content/QV_QMC/QMC_Documents_SourceDoc...

I have provided a couple of Help links above too that may be of some help too.  Sorry, just saw your other answer regarding Section Access, so that is good, but is there anything configured in the other menu I mentioned above in that case?  That would be the only other thing of which I can think that would be going wrong with things.

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
Vengatesh
Partner
Partner
Author

Hi, Sorry for the dealyed response

Created two fresh reports, seems to work fine.

I suspect the issue might be, I Renamed the new Report with Old name and Old Report with new name.

You Know What To Do.

View solution in original post