Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

cancel
Showing results for 
Search instead for 
Did you mean: 
pontus_agren
Contributor II
Contributor II

2GB qvw files takes long time to start/save, what could speed up the process?

Hello.

I have some qvw-files that are over 2GB and it takes a while for them to open up and save them, which is a bit frustrating. Up to 30 seconds.. Yes, I know 30 sec might not sound too much, but if there are any trix, what could speed up the process? Is it hardware related? Or is this maybe what I can expect of 2GB documents? It's slow in access point aswell, and I will hear more about that pretty soon Im sure . It's fairly fast when all is loaded. but the start and save processes are hideous

The data-model's are fine as far I can see in my reports.

The server hardware specifications:

32G RAM,

Intel(R) Xeon(R),Dual core, 3 GHz.

Windows Server 2008.

Could a hardware upgrade help? Has the current setup any bottlenecks? Anything more you need to know (most likely) before answering. What has helped others to speed up their slow document? Maybe I posted this in the wrong subforum, feel free to move it..

1 Solution

Accepted Solutions
Peter_Cammaert
Partner
Partner

In your AP, there is a simple switch to flick for every large document that is needed by a lot of users. In the QMC, look for the Preload checkbox, and enable it for all documents that experience long delays the first time they get loaded.

For QV Desktop it's a bit give&take. Most of the time for loading and saving a QVW goes into complessing/decompressing the data inside your data model. So the simplest thing you can do (if you're gonna perform a reload anyway) is to open a document without data.

Another technique is to set the compression level to None (see Settings->Document Properties->General->Save Format) and that will recover most of the time needed to compress your data model. Flipside: your QVW files grow on average 4 to 10 times in size.

And then there is a whole range of optimisation options that make your document load less data.


Best,


Peter

View solution in original post

4 Replies
juraj_misina
Partner
Partner

Hi,

in my experience load/save times improved when we moved files from HDD to SSD disks. If your files are on a network drive, make sure network connectivity is working perfectly.

Hope this helps.

Juraj

Peter_Cammaert
Partner
Partner

In your AP, there is a simple switch to flick for every large document that is needed by a lot of users. In the QMC, look for the Preload checkbox, and enable it for all documents that experience long delays the first time they get loaded.

For QV Desktop it's a bit give&take. Most of the time for loading and saving a QVW goes into complessing/decompressing the data inside your data model. So the simplest thing you can do (if you're gonna perform a reload anyway) is to open a document without data.

Another technique is to set the compression level to None (see Settings->Document Properties->General->Save Format) and that will recover most of the time needed to compress your data model. Flipside: your QVW files grow on average 4 to 10 times in size.

And then there is a whole range of optimisation options that make your document load less data.


Best,


Peter

YoussefBelloum
Champion
Champion

Hi,

you should make your benchmarking on the accesspoint, you will have a better idea on how much time the app takes to open and finish all the starting calculations.

what type of expressions/functions you use on the first page for example ?

pontus_agren
Contributor II
Contributor II
Author

Sorry for the late reply. That simple switch did it for the AP, which is the most important. I will consider setting the compression level to none.

Thanks for the info!