Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Support Case Portal has moved to Qlik Community! Read the FAQs to start exploring Support resources.
cancel
Showing results for 
Search instead for 
Did you mean: 
elie_issa
Creator II
Creator II

Access point Tunnel issue

Dear All,

Please find below the error shown when trying to access the qlikview dashboard from the access point.

For more info we have one live server and one cluster server linked to each others to give better performance and balance if many users are accessing the dashboards.

Capture.PNG

What it could be the cause of such error ?

Thanks a lot

1 Solution

Accepted Solutions
hani_saghir
Contributor III
Contributor III

check the TicketCal.PGO and XML files, if they are corrupt, they can cause this behavior.

you need to back them up and delete them, the system will recreate them. this did the trick in our environment.

View solution in original post

8 Replies
cristinapo
Contributor III
Contributor III

Hi Ellie, is this the first time you try to access it in Access Point? Maybe you don't have access.

Chip_Matejowsky
Support
Support

Hello Elie,

Can you please provide greater clarity on this issue?

  • QVW is hosted on the AccessPoint and end-user is attempting to open it and receives the tunneling.dll error?
  • What client is the end-user using? I presume it's the IE Plugin.
  • Does the AJAX client work without issue?

The IE Plugin client uses the QVP protocol to communicate from the client to the QVS server. The QVP protocol strictly uses port 4747 for communication. If port 4747 is not open, then communication will "tunnel" via port 80/443. Tunneling does have to be configured on the QlikView Server and IIS server if using IIS as webserver.

Check QMC > System > Setup > QlikView Web Servers > QVWS@ > AccessPoint tab > Server Connections tab. Is the Always Tunnel checkbox ticked?

You can use the Telnet command to test if port 4747 is open.
1. Open a command prompt on client computer

2. Enter: Telnet <servername or IP address> port 4747

3. If a cursor is returned, then port is open; if something other than cursor is returned, then port is not open

If Telnet is not enabled on computer:

1. Click Start > Control Panel

2. Click Programs

3. Click Turn Windows Features on or off

4. In Windows Features dialog box, tick the Telnet Client check box

5. Click OK to allow system to install the client

6. Perform the Telnet command described above

Hope this helps,

Chip

Sr. Technical Support Engineer with Qlik Support
Help users find answers! Don't forget to mark a solution that worked for you!
elie_issa
Creator II
Creator II
Author

Always Tunnel checkbox was not ticked. should we restart the server after we check it ?

elie_issa
Creator II
Creator II
Author

Hi Chip,

I tested the access to port 4747 on my Server and  it worked properly.

but still we are facing the tunnel issue again and again.

It could be from the IE Plugin ?


Any alternate solution ?


Thanks again.

Chip_Matejowsky
Support
Support

Hey Elie,

Did you confirm what client users are using when error is received? If IE Plugin client only, is port 4747 opened on those users's computers? Did you confirm if AJAX client works?

I have seen the tunnelling.dll issue when the external name of the server differs from the internal name. This is mitigated by the

Check QMC > System > Setup > QlikView Servers > QVS@ > General tab > Link Machine Name field. See the below definition of Link Machine Name from the online QlikView Help:

If the QlikView Server cluster is not exposed externally with the same name as is used internally, an external name must be entered in this text box. This is to enable QlikView documents in the Microsoft Internet Explorer plugin. To mimic the behavior of version 8.5, it is possible to enter (FromRequest) (including the parenthesis) in this text box. The name exposed externally will then be the same as the URL that the client uses to connect to the QlikView AccessPoint, that is, the setting is taken from the request coming from the client.

Hope this helps,

Chip

Sr. Technical Support Engineer with Qlik Support
Help users find answers! Don't forget to mark a solution that worked for you!
elie_issa
Creator II
Creator II
Author

Hey Chip,

Below is the link machine name empty. do you suggest to put same name for the two servers or we have to do anything else ?

Capture27.PNG

Thanks.

Chip_Matejowsky
Support
Support

Hey. Would suggest that you enter (FromRequest)

Sr. Technical Support Engineer with Qlik Support
Help users find answers! Don't forget to mark a solution that worked for you!
hani_saghir
Contributor III
Contributor III

check the TicketCal.PGO and XML files, if they are corrupt, they can cause this behavior.

you need to back them up and delete them, the system will recreate them. this did the trick in our environment.

View solution in original post