Skip to main content

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Welcome to Qlik Community! Check out our new navigation! FIND OUT MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Adding data labels to just last point on time series graph

Is there an easy way to add the value of the right-most point of a time-series graph? This would make it easy to identify what the value is exactly.I don't want every point on the graph labeled, though.

The expression for my trend graph looks like this:

=

rangesum(above(sum([Member Count]),0,12))

/

rangesum(above(sum([Member Count]),12,12))

-1

Dimension is Month.

1 Solution

Accepted Solutions
stephencredmond
Luminary Alumni
Luminary Alumni

Hi,

Have a look at the attached example.

Regards,

Stephen

View solution in original post

10 Replies
stephencredmond
Luminary Alumni
Luminary Alumni

Dual might work.

Something like:

dual(if(Dim1=[last value in dimension], 'Label i want', ''), Count(Dim1))

Regards,

Stephen

Not applicable
Author

I don't think the Dual function is what I'm looking for. Attached is a mock-up of what it would look like.

stephencredmond
Luminary Alumni
Luminary Alumni

Hi,

Have a look at the attached example.

Regards,

Stephen

Not applicable
Author

Thanks for the example. I've tried using your expression

Dual(

if(Month='$(=Max(Month))', Num(Avg(Perc), '0.0%'), ''),

Avg(Perc))

and replacing "Ave(Perc)" with my function, but had no luck.

stephencredmond
Luminary Alumni
Luminary Alumni

Hi,

It is not really to do with luck.

Make sure that you have no format (expression default) specified in the number tab.  you have "Value on data point" specified.

Of course, I have no clue as to what is the problem because I don't have your data and "I had no luck" isn't really a great problem description.

Regards,

Stephen

Not applicable
Author

Stephen, your advice has certainly increased my luck. I can now get the value of the final point to be displayed at the bottom of the graph, at least. I did this by also checking "Text on Axis" as a Display Option on the Expressions tab.When I uncheck this box, the value disappears. I appreciate your help on this problem.

stephencredmond
Luminary Alumni
Luminary Alumni

Hi,

If you copy my chart into your document and modify the dimension and expression, does it work?

Do you have multiple dimensions or multiple expressions to achieve the 3 lines?

Regards,

Stephen

Not applicable
Author

If I copy your example it works! Now I just need to figure what was different for me. Thanks again!

Not applicable
Author

The problem is occuring when I add more than one expression to the graph. It can't seem to handle more than 1. When there are 2, they both work when only one is enabled. But, when both are enabled, the % disappears. The trend line still shows.