Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Become an analytics expert with Qlik's new 15 week course: Applied Data Analytics using Qlik Sense. READ MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Autnumberhash128 doesn't work

Hello i have two tables i need to link

i already have the elements for each to consitute the common key, when i use autonumberhash128  to constitute the key the relation between the two tables is not established (subset ratio on first table =23% and the other is 77 % which means that the tables don't have common values in their keys) , when i use just a simple concatenation of the fields (field1&Field2&Field3)  on the keys of  both tables , the relation is established their are common values.

How do you explain this issue?

Thanks in advance for your answers

8 Replies
Clever_Anjos
Employee
Employee

Please post your code to check how you´re using the function

Not applicable
Author

Are you using the AutonumberHash128 function for both tables on the same qvw ?

Not applicable
Author

Yes I am using it on both tables

Not applicable
Author

autonumberhash128(field1, field2, field3,field4) as key ( on both tables doesn't work)

if I use

field1&'|'& field2&'|'&field3&'|'&field4  as key            (on both tables it works)

bruno_m_santos
Partner
Partner

I suggest autonumberhash128(field1&'|'& field2&'|'&field3&'|'&field4).

It 'll work for sure.

Bruno

Not applicable
Author

both tables are loading in same qvw ?

Not applicable
Author

the thing is one of the two keys in question is linked to multiple other tables, i need to link a new table to the already existing tables (Three tables using the same key, need to add the fourth one with the same key ),  the three first tables keys are all calculated with autonumberhash128(), when i tried to add the fourth table to them, it didn't work 

Not applicable
Author

yes they are in the same qvw