Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Support Case Portal has moved to Qlik Community! Read the FAQs to start exploring Support resources.
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

BAR CHART LEGEND POP UP


The attached Bar Chart is using Question as Legend. When I Hover over the Question Legend I should be able to see the Whole quetsion. BUt its not happening.  Is there an option to see the whole text in the Legend when Hoverered Over.

Plese Help    

12 Replies
Not applicable
Author

Hi,

There is an option to use text as pop-up under the expresion tab. Does that solve your problem?

Not applicable
Author

NO cuz that works for Expression ONly as Pop UP. I am trying to achieve is if USER Hover Over the Legend (Question) in this case should be able to see the whole Question

Not applicable
Author

You can have the question dimension as an expression as well. And then untick the bar box under "display options" in the "expression tab". Was that understandable?

Not applicable
Author

That doesnt work, If I remove it as a Dimension I dont get Any Legend??

jsaradhi
Specialist
Specialist

Jon is suggesting not removing Question from dimension. Leave it in dimension since you need the legend. Additionally, add Question as an expression and uncheck the bar option in display options for this expression.

another work around is a) do not display legend from your bar chart. b) clone the bar chart and make the new bar chart a straight table. then hide all the columns except Question. in dimension, check show all values and make the table read only if you have to and place it right where the original legend is located.

Not applicable
Author

I dont wanna clone it cuz then  I wont be able to see teh Color Boxes corresponding to each Legend

tobias_klett
Partner
Partner

Hi Ray,

try using the dual Function and add everything you want to read in the text-part and the expression as it is in the number-part. Make sure on Numbers-Tab you are on expression default and format your number in the text-part.

dual(    Dimensionfield & ' ' & num(sum(XY),'#,##0') ,     sum(XY)    )

Hope this helps

Not applicable
Author

Doesn't Work

tobias_klett
Partner
Partner


did you put your the dual around your expression like that?
dual( dimensionfield & expression, expression)
Did you switch to the numbers-tab and make sure this expression is on default?