Skip to main content
Announcements
You can succeed best and quickest by helping others to succeed. Join the conversation.
cancel
Showing results for 
Search instead for 
Did you mean: 
warfollowmy_ver
Creator III
Creator III

Bug! Quickly! QlikView November 2017 SR1 and SR2 and SR3. Tell the developers!

Bug! Quickly! QlikView November 2017 SR1 and SR2 and SR3. Tell the developers!

After reload script the document in desktop, triggers do not see macros!

While I understood this, I broke my head! Tell the developers!

Open the document in the latest version of the desktop QV and click on the reload... If you run the macro after opening, everything works, if you first reload, then does not see the trigger of macro...

1 Solution

Accepted Solutions
sfatoux72
Partner - Specialist
Partner - Specialist

‌No it’s not normal, it’s a bug introduced with the new BNF script reload mode.

The bug is reported to Qlik R&D and they work to correct it.

In the meantime, you need to stop the new “BNF script reload mode” on application where it’s necessary, like recommended by Qlik on the same document.

View solution in original post

18 Replies
felipedl
Partner - Specialist III
Partner - Specialist III

Hi,

Both ways work for me and I have November SR1 patch.

Only thing I've seen is that when I click the "Reload" button, I have to switch programs (Alt+Tab) so that the reload data message box can be closed, because it freezes up for some reason, and the macro is executed.

Might be something with your local settings, but if I open up a new document and put a message box it works fine.

As I tested it, it wouldn't be considered a bug.

Felipe.

warfollowmy_ver
Creator III
Creator III
Author

Made a video, you need to open a document, click on the button. That is, immediately after the opening and reload...

I do not know what I'm doing wrong, it's already checked on three machines...

We did not change any settings...

felipedl
Partner - Specialist III
Partner - Specialist III

Made exactly as you stated and worked fine for me, just changed the string you were using (the russian alphabet I assume) to Hello World or whatever string and worked ok.

Didn't see any strange behaviour on my end.

warfollowmy_ver
Creator III
Creator III
Author

Installed at home, checked, the same mistake ... It's funny...

Let's have someone else put and check, we until two, until 50/50...

rwunderlich
Partner Ambassador/MVP
Partner Ambassador/MVP

When I reload right after opening, I get the macro window popup as in your video. If I press Cancel and reload again, it works.

I don't know where the problem may be but you might want to talk to QT Support.

-Rob

sfatoux72
Partner - Specialist
Partner - Specialist

Hello,


I encountered exactly the same problem.

Have you contacted support about this, or have you found a solution?

Thanks

warfollowmy_ver
Creator III
Creator III
Author

Hi!

The only solution is to fix the bug to the developer. No others. I rolled back the previous release. That's all I can do for now.

warfollowmy_ver
Creator III
Creator III
Author

There was an update 12.20.20300, but the problem remains, some kind of shame ...

rwunderlich
Partner Ambassador/MVP
Partner Ambassador/MVP

Have you opened a case with support?  Discussing a bug in this forum will not get the issue reported to Qlik R&D.

-Rob