Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Coming Aug. 9: New Simplified Authoring for Qlik Sense SaaS – For Details, CLICK HERE
cancel
Showing results for 
Search instead for 
Did you mean: 
praveenr035
Contributor III
Contributor III

Button actions not working from AccessPoint

Hi, Can some one suggest recommended settings/things to check to run QV11 report from access point. One of the report users complained about button functionality not working (all buttons in report). Even simple button action for setting a variable value is not working when report is opened via Access Point. We tried multiple things and no luck so far. The same functionality works fine to other users.


Here are some of the changes we did, appreciate any help in this regard, Thanks in advance!

Installed IE plug-in, checked IE compatibility mode,enabled certain internet options (activex objects), chose "Give System Access to Module Script"(Ctl+Shft+M) option (as some buttons have macros).


Note: this user has installed QV Desktop locally for other purpose

8 Replies
bindu_apte
Creator III
Creator III

Hi Praveen,

Let me know what version of qlikview using means SR?

Some issue in SR5 and SR6 if you are using Chrome or firefox as browser to open accesspoint.

lawrenceiow
Creator II
Creator II

Did you ever get a solution to this as I've just encountered the same problem.

I have tested with a simple button to Activate SH02 but this does not work, I un-ticked (or "un-checked") the Hide Tabrow setting and the user could select Sheet 2 but not via action button.

If I find a solution I'll add it here, until then, any help would be appreciated.

Sergey_Shuklin
Specialist
Specialist

Hello!

Is problem stays if you do an action not with a button, but with text objects?

lawrenceiow
Creator II
Creator II

serj_shu‌, , I have added a Text Object which has the same Action as the Button but this still does not work for that user (it works OK for me).

Regards

slefranc
Partner - Contributor II
Partner - Contributor II

Hi Lawrence,

Experiencing exactly the same thing on one of my colleagues' computer.

Did you find an explanation... and a solution ?

Thanks

Samuel

lawrenceiow
Creator II
Creator II

Samuel,

We've only just discovered (a couple of days ago) that the users who can't use the action buttons are on SR13 and those that can are SR12. I believe the dashboard was developed with SR12, we are awaiting our IT dept to get everyone to the same version and then we'll try again.

I'll update here once we're all confirmed (if that was indeed the answer) to be working ok. Due to users being on annual leave I may not have an answer for a couple of weeks.

Lawrence

Rahul_03
Partner - Contributor II
Partner - Contributor II

Hi Lawrence,

We also encountered the same issue, do you have any solution for this issue?

Thanks

Rahul.

GabrielBejar
Contributor
Contributor

Hi 

Please note the full given answer at

https://community.qlik.com/t5/Knowledge/quot-Open-URL-quot-and-quot-Launch-quot-disabled-for-documen...

In resume:

"Open URL" and "Launch" were disabled for document sheet buttons in latest QlikView Plugin releases 
 

A document sheet can have buttons, which in turn can have associated Actions. 

These Actions can be of several types, but there are two in particular which have been disabled in the Internet Explorer Plugin due to security concerns:

  • Launch
  • Open URL

Resolution