Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
We value your feedback – take our 5-minute QlikView modernization survey
cancel
Showing results for 
Search instead for 
Did you mean: 
johnhorneramllp
Partner - Contributor III
Partner - Contributor III

Combo Chart with 2 Dimensions - symbols not being placed correctly

We have a requirement to present a combo chart with 2 metrics as bars (stacked) and 1 metric as a symbol against 2 dimensions. The bars are stacking perfectly but the symbols are not being plotted in the right location for the second dimension. Please see attached example, if you flip to a straight table, or indeed hover over each symbol you can see that the data is indeed matched correctly just that the symbol is not apearing in the correct place…any suggestions or fixes for this would be greatly appreciated?

Regards

John H

4 Replies
Not applicable

Hi,

The only solution I can think of is to use trellis.

Best regards!

johnhorneramllp
Partner - Contributor III
Partner - Contributor III
Author

Agreed, indeed we have already done this and it works ok for sure, though not precisely what the customer asked for. I wanted to confirm that i am not missing anything obvious and hopefully receive some feedback from QlikTech re. whether this is a bug in the combo chart rendering that can perhaps be fixed in a future version.

Regards

John Horner

johnw
Champion III
Champion III

It does look like a bug to me, related to having two dimensions. That suggests another workaround, which is to use a single concatenated dimension:

=Dim1 & ' ' & Dim2

It works. Not as readable as just using two dimensions, but at least the data shows up in the right spot. It's at least an alternative to using a trellis chart. I think the trellis is more clear, but may make it more difficult to make certain kinds of observations.

johnhorneramllp
Partner - Contributor III
Partner - Contributor III
Author

Thanks John / Gabriella for the alternate solutions...still waiting on response frm QlikTech support...i will update this post accordingly as soon as i hear anything.

Regards

John H