Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Now Live: Qlik Sense SaaS Simplified Authoring – Analytics Creation for Everyone: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Conditional colour formating in pivot table for Dimensions not working

Hi..i have strange problem..i just want show the "Days" column of the attached file with Red background with following conditions

1. When Days >= 30 days, Background color of Days Dimension should be red

2.Dont change the table structure ..it should remain like that only

3.in current file color is showing for some values which are > 30, for some other even if it is 120 days background color doesn't change.

I have attached the file kindly help me

thanks in advance

1 Solution

Accepted Solutions
rajat2392
Partner - Creator III
Partner - Creator III

Hi Vinod,

Check the application I've attached.

I have unchecked the "Suppress Zero-Values" and "Suppress Missing" and checked the "Populate Missing Cells" in presentation tab.

I have done a small change in expression also, else instead of "-", 0 will come.

Regards

Rajat Arora

View solution in original post

9 Replies
giakoum
Partner - Master II
Partner - Master II

uncheck "suppress zero values" in the presentation tab

antoniotiman
Master III
Master III

Dimension 'Curr' is Horizontal.

In Vertical it works.

Not applicable
Author

unchecking suppress zero doesn't work

rajat2392
Partner - Creator III
Partner - Creator III

Hi Vinod,

Check the application I've attached.

I have unchecked the "Suppress Zero-Values" and "Suppress Missing" and checked the "Populate Missing Cells" in presentation tab.

I have done a small change in expression also, else instead of "-", 0 will come.

Regards

Rajat Arora

jsingh71
Partner - Specialist
Partner - Specialist

Hi,

Find the qvw.

--Jai

Not applicable
Author

Hi..can u explain me what you did...

Thanks

rajat2392
Partner - Creator III
Partner - Creator III

he has done the same thing what I have done...

Unchecked the "Suppress Zero-Values" and "Suppress Missing" and checked the "Populate Missing Cells" in presentation tab.

But he has done no change in expression so instead of null sign "-", 0 is coming. Else everything is same.

Not applicable
Author

Thank you all for your replies..i fixed the issue as you suggested

jsingh71
Partner - Specialist
Partner - Specialist

I re-write the background expression because you forget to '=' sign and also the expression in expression tab.

and its working fine for me.

--Jai