Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
QlikView forum consolidation is complete. Labels are now required. LEARN ABOUT LABELS
cancel
Showing results for 
Search instead for 
Did you mean: 
userccsmaia
Contributor II
Contributor II

CsMaia

Estou realizando análises de dados extraídos de chats do WhatsApp, porém alguns caracteres (emojis) são reconhecidos pelo WhatsApp e outros não, por exemplo:

Esse  é reconhecido no Qlikview

Já este  💕 aparece o texto  _xD83D__xDC95 em vez de aparecer a gravura.

Alguém sabe se tem como atualizar o Qlikview para que o mesmo reconhece esses novos caracteres ?

 

 

Labels (3)
1 Solution

Accepted Solutions
lftensini
Partner
Partner

Compartilhe o seu arquivo de origem, ou ao menos no trecho, que possui esses caracteres para eu realizar um teste por aqui. Se possível o seu QVF do Sense também. Pode haver mais de um problema envolvido, pois eu mesmo tenho uma aplicação que lê do WhatsApp e apresenta todos os emojis.
Support your colleagues. Remember to "like" the answers that are helpful to you and flag as "solved" the one that helped you solve. Cheers.

View solution in original post

5 Replies
lftensini
Partner
Partner

Olá amigo.

De uma maneira curiosa, o QlikView identifica esses caracteres caso você abra um objeto de texto e cole isso dentro dele, porém no objeto em si ele não é representado corretamente. Há uma limitação de posições do conjunto de caracteres para isso.

A boa notícia é que no Qlik Sense este tipo de caractere é reconhecido naturalmente.

Espero ter ajudado, forte abraço.

Support your colleagues. Remember to "like" the answers that are helpful to you and flag as "solved" the one that helped you solve. Cheers.
userccsmaia
Contributor II
Contributor II

Olá,

realmente curioso, sua resposta ajudou sim e fico grato pela atenção.

Vou partir para criar a aplicação no QlikSense.

Obrigado !

 

userccsmaia
Contributor II
Contributor II

Criei uma aplicação no QlikSense e assim como no QlikView os dados(caracteres/emojis) não foram reconhecidos.

 

Vou passar mais detalhes.

Estou carregando esses dados de uma planilha excel e na planilha os caracteres aparecem normalmente, conforme imagens anexas.

Trecho do código com o LOAD:

"..... FROM
[Dados\TABELA.xlsx]
(ooxml, embedded labels, header is 1 lines, table is Chats);"

 

Porém quando chega nos objetos tabela, tanto no QlikView como no QlikSense os caracteres não são visualizados corretamente, aparecem os códigos hexadecimais dos mesmos, por exemplo :

"_xD83D__xDC4D__xD83C__xDFFB__xD83D__xDC4D__xD83C__xDFFB__xD83D__xDC4D__xD83C__xDFFB_levo suco"

 

lftensini
Partner
Partner

Compartilhe o seu arquivo de origem, ou ao menos no trecho, que possui esses caracteres para eu realizar um teste por aqui. Se possível o seu QVF do Sense também. Pode haver mais de um problema envolvido, pois eu mesmo tenho uma aplicação que lê do WhatsApp e apresenta todos os emojis.
Support your colleagues. Remember to "like" the answers that are helpful to you and flag as "solved" the one that helped you solve. Cheers.

View solution in original post

userccsmaia
Contributor II
Contributor II

Infelizmente não posso colocar o arquivo de dados por serem sigilosos, porém após fazer alterações na planilha e salvar em uma nova versão do Excel os emojis apareceram no QlikSense e no QlikView aparecem como um Quadrado.

Assim, acho que o problema é o formato inicial de onde recebo a planilha e a solução é realizar uma alteração e salvar em uma versão nova do Excel para após realizar a carga.

Grato pela atenção novamente.