Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Coming Aug. 9: New Simplified Authoring for Qlik Sense SaaS – For Details, CLICK HERE
cancel
Showing results for 
Search instead for 
Did you mean: 
rakesh_kumar
Creator
Creator

Currency symbol in a straight table not appearing

Hi Guys,

I have a problem with a currency symbol in an expression in the straight table below:

Capture 1.JPG

I am using the following expressions:

Spend

=Money($(=Field_name), Metric_format)

QTD Accumulation

=if(isnull(YearWeek), null(), Money(rangesum(above($(=Field_name),0,rowno())),Metric_format,'.',','))



Here is the table containing, Metric and Metric format values in the data model:

Capture 2.JPG


The problem here is, "Spend" is working correctly by showing the '$' symbol, where as "QTD Accumulation" is not showing the '$' symbol.


How can the expression for "QTD Accumulation" needs to be changed to show '$' symbol for the values in the straight table?

1 Solution

Accepted Solutions
rubenmarin

Hi Rakesh, PFA.

Check the expression and number tabs (I set the format to 'prefedefined expression' in numbers tab)

View solution in original post

10 Replies
MK_QSL
MVP
MVP

What is the MoneyFormat set at script?

SET MoneyFormat='$#,##0.00;-$#,##0.00';

Peter_Cammaert
Partner - Champion III
Partner - Champion III

Manish, he tries to use the format specification that is stored in field Metric_format. For expression "Spend" it works, for "QTD accumulation" it does not.

Rakesh, are you sure this expression is what is used in column "QTD accumulation"? Because the numbers don't seem to add up after the first month...

rakesh_kumar
Creator
Creator
Author

Hi Manish, as Peter said I used the format in the table in data model above.

Yes Peter this is the expression. Yeah there might be some problem with the values, but main objective is to get the dollar symbol for the values. Please could you guys let me know how to achieve this?

Gysbert_Wassenaar

Can you post a small Qlikview document that demonstrates the problem?


talk is cheap, supply exceeds demand
Peter_Cammaert
Partner - Champion III
Partner - Champion III

Any change if you omit the separators part ('.',',') from the Money parameter list? Are the settings in the Number tab the same for each expression?

rakesh_kumar
Creator
Creator
Author

Please find the attached App. Please can anyone help fixing the issue?

rubenmarin

Hi Rakesh, PFA.

Check the expression and number tabs (I set the format to 'prefedefined expression' in numbers tab)

Gysbert_Wassenaar

See attached qvw.


talk is cheap, supply exceeds demand
rakesh_kumar
Creator
Creator
Author

Thanks a lot Ruben & Gysbert, both your solutions are working. If there is an option I would have selected both of your answers as correct