Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
QLIKWORLD LIVE! MAY 16 - 19TH, EARLY BIRD DISCOUNTS! REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Current Selections not updated after value is excluded

Hi,

Background: I have noticed, that Current Selections box is not updated when one or multiple value become excluded/unavailable. For example - let's consider two similar tables, connected with key field Key:

Table 1
KeyValue1
Key1Table1-Value-Key1
Key2Table1-Value-Key2

Table 2
KeyValue2
Key1Table2-Value-Key1
Key2Table2-Value-Key2

Steps to reproduce: If I create Current Selections box and two filters using fields Value1 and Value2, I can do the following:

  1. Select all in Value1
  2. Select all in Value2
  3. Deselect one of the options in either of the filters (let it be Table2-Value-Key1 for this example)


Result: both filters have only one option selected (Table1-Value-Key2 in Value1 and Table2-Value-Key2 in Value2), as expected. But in Current Selection I still see both - Table1-Value-Key1 and Table1-Value-Key2 in Value1.


Expected: in current selection I see only Table1-Value-Key2 in Value1.


Environment: I use QlikView 12.10 SR3 12.10.201000.0. First noticed this behavior on this version, so I don't know if this is reproducible in older version.

This happens on both - QlikView Desktop and Server (using AJAX). No idea about IE plugin.

I have attached screenshot and a small app the reproduce this.

Is there a reason behind this or is this an issue with QlikView?

Thanks! !

1 Solution

Accepted Solutions
Not applicable
Author

QlikTech support pointed me towards this post: Colors, States and State vectors

It really well explains what is going on.

This is normal behavior after all.

View solution in original post

2 Replies
marchoctober
Creator
Creator

Hi! I tested on 11.2 SR12 & 12.10 SR1 & Q Sense 3.1x, all getting the same result as you described. Current Selections values are not override.

This means issue is not in particular QV version but in smth we do not understand.

Not applicable
Author

QlikTech support pointed me towards this post: Colors, States and State vectors

It really well explains what is going on.

This is normal behavior after all.