Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Join this live chat April 6, 10AM EST - QlikView to Qlik Sense REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Cycle Shows Twice

Can anyone tell me how to get rid of the second cycle through?  Looks like a bug, but maybe I am just missing something obvious.

Capture.JPG

Sample file attached.

1 Solution

Accepted Solutions
Gysbert_Wassenaar

Looks like a bug to me. QV 11.2 here. I managed to drag one of the two buttons to below the chart bottom (keeping shift+ctrl keys pressed down and drag the darn thing downwards) so only one shows. Weirdly enough the cycle group you move stays where it is and the other one is moved to where you dragged the first one... go figure. So drag the bottom group button to invisibility so the top one disappears from view.


talk is cheap, supply exceeds demand

View solution in original post

9 Replies
khadeer_sparks
Specialist
Specialist

Hi,

Here i am seeing only one cyclic group only in ur QVW file.

check the image

Not applicable
Author

There is only one cycle group, but the button to cycle through the expressions shows up twice in the graph. The user sees the same thing twice.

alexandros17

You have one cycle in the dimension and one in the expressions, this one must be deleted ...

hope it helps

Not applicable
Author

Thanks but that is my intention. The problem isn't that I have a cycle for dimension and a cycle for expressions. It is that the cycle button is duplicating.

Gysbert_Wassenaar

Looks like a bug to me. QV 11.2 here. I managed to drag one of the two buttons to below the chart bottom (keeping shift+ctrl keys pressed down and drag the darn thing downwards) so only one shows. Weirdly enough the cycle group you move stays where it is and the other one is moved to where you dragged the first one... go figure. So drag the bottom group button to invisibility so the top one disappears from view.


talk is cheap, supply exceeds demand

View solution in original post

Not applicable
Author

Okay, thanks Gysbert.  That will have to suffice for now. I will submit it as a bug.

mphekin12
Specialist
Specialist

Capture.PNG

Rebecca,

I only see two cycle groups.  I tried moving the expression cycle group by using the shift+ctrl keys and I was still unable to duplicate your error.  You might want to try to delete the chart and rebuild it from scratch.

Not applicable
Author

Must be a version thing then. Thanks for looking, mphekin12.

philbishop
Creator
Creator

I just tested this in V11.20 SR4 (Build 12123) and it looks like it is resolved. In my case, I had multiple expressions in a combo chart but only one was a cycle expression. I was getting cycle icons for as many expressions as I had enabled (3 expressions plus a cycle expression would result in 4 icons). I saw the error in SR2. In SR4, we are back to a single cycle icon.

(I did not test in SR3, so it may have been resolved sooner)

-Phil