Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Support Cases coming to Qlik Community Oct. 4! Start chats, open cases, explore resources: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
qk_eckpoon
Contributor
Contributor

Cyclic Group - Year/Month/Date comparison

Hi, 

I have a problem here for a profit comparison between two years. I created a cyclic group using Year/Month/Date as dimension in the bar chart. The Date dimension(in the cyclic group) has an expression which is equal to

=MakeDate(Year(Localtime()), Month(Date), Day(Date))

The calculated dimension on y-axis of the bar chart represents the profit = margin * volume sold.

The problem happens, for instance, I select April and 2019 both fields, date as the x-axis dimension, then choose one of the products selling. The bar chart shown in the future date (i.e. a date has not been passed) with a high value figure from previous year.

screenshare.jpg

When the product field is deselected, the figures shown in the bar chart is back to correct value. All passed dates their values show on both screens are the same.

screenshare02.jpg

If I select on single date, in the bar chat, it looks correct.

screenshare03.jpg

I am new to QV technology and I would like someone to tell me how to tackle this problem. By hiding the future date figure using set analysis is not an option.

2 Replies
arpitkharkia
Creator III
Creator III

You can look into articles explaining master calendar. I think once you use that, it will be resolved as i believe the values are coming from a different table.

If you can attach a sample app, it will be great!

Regards

Arpit

qk_eckpoon
Contributor
Contributor
Author

Unfortunately, I am unable to share the actual app. The master calendar the app used basically derived from a stored procedure in database as shown below. The dimension table used for the calculated expression are also based on the same date format.

screenshare.JPG

I have also attached the data model used the app as below. I suspect the problem is from the OwnSiteDetails dimension not linking directly as other dimension tables.

model.jpg