Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Date Picker Bug on Access Point?

It seems there is a bug with the Date Picker on Access Point.  We are using QlikView 11 SR15. 

I have attached a simple app that contains just one field (My_Date) and has a date picker in it.  The date picker is only supposed to allow dates between the Min(My_Date) (5/1/2009) and the Max(My_Date) (12/31/2015).

When opening this in Qlik Desktop, it works as expected (the minimum date you are allowed to pick is 5/1/2009.   However, when it is loaded onto Access Point it actually show April 2009 and allows you to pick 4/30/2009.  What is interesting, is if you pick that date, it actually sets the variable at 5/1/2009.  It seems to only happen with the minimum date... the variable gets set according to the rules, but the calendar picker displays an extra day (and since the minimum is the first of the month it shows an extra month)

date_picker.png

Has anyone else seen this, or know of a workaround/fix for the problem?

3 Replies
vishsaggi
Champion III
Champion III

Does your excel sheet has any hidden data for April? On my end it works fine even in access point. When in accesspoint you can see Apr month in the drop down when you select 2009 ?

Not applicable
Author

There is nothing hidden in the Excel file.  We originally found this problem with another data source (and I just used Excel to duplicate it).  I could build the app with just an inline load and get the same results (it works in the Desktop app, but shows an extra day at the beginning in Access Point).  The screen shot I posted (with Apr month in the drop down) is from Access Point. 

Here is a screenshot of the same date picker on the desktop:

date_picker_dt.png

and the same on Access Point:

date_picker.png

vishsaggi
Champion III
Champion III

Thats strange...Sorry Todd, i am out of ideas on where to check. It should not be a bug, coz it works at my end. I am using QV 11.20 SR5.