Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Join us for a live Q&A! September 21, 10 AM ET - Onboarding Fast in Qlik Sense SaaS! REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
amruta_j
Partner
Partner

Default dimension in Cyclic group

Hi all,

I've Cyclic dimension for Year, Month and Date. I need to select Date as default dimension.

I tried to create bookmark and that way it is working fine in desktop version, but not on access point.

Can you please help me in this.

Thank You!

 

Labels (2)
1 Solution

Accepted Solutions
dapostolopoylos
Creator III
Creator III

As far as i know, the default dimension of a cyclic group is the one that is on the top selection when the document is saved. For example if you have a cyclic group with two dimensions, Sales District and Country if you save your document with Sales District selected then by default the document will open with Sales District displayed on the cyclic group.
Father/Husband/BI Developer

View solution in original post

5 Replies
amruta_j
Partner
Partner
Author

Can someone please help me to set default dimension in Cyclic Group on access point...

dapostolopoylos
Creator III
Creator III

As far as i know, the default dimension of a cyclic group is the one that is on the top selection when the document is saved. For example if you have a cyclic group with two dimensions, Sales District and Country if you save your document with Sales District selected then by default the document will open with Sales District displayed on the cyclic group.
Father/Husband/BI Developer

View solution in original post

amruta_j
Partner
Partner
Author

Thanks for your reply. I tried that solution. But on accesspoint after opening the report if I choose Month instead of date and close the dashboard, next time when I open the dashboard Cyclic will show Month as it is selected last time. 

Everytime I'm not able to reset it to Date.

Vengatesh
Partner
Partner

This is happening because of the caches. you should click on the Remove last document state while opening the document. You can find that option on view details button below the application
You Know What To Do.
Brett_Bleess
Support (Former)
Support (Former)

The other side to the above post is whether or not the QlikView Administrator has enabled the Allow Session Recovery feature in the Management Console\System\Setup\QlikView Server resources\specific QVS instance\Documents tab settings.  If that is checked, whatever is set at the end of the user session is saved to a 'LastKnownState' server bookmark, and that bookmark is recalled when the user returns the next session.  Here is the Help content on it as well:

https://help.qlik.com/en-US/qlikview/April2019/Subsystems/QMC/Content/QV_QMC/QMC_System_Setup_QlikVi...

Hope this helps a bit more.

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.