Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Showing results for 
Search instead for 
Did you mean: 

Document property for pivoting ?

Hello All,

I am only a newbie to Qlikview so please bare with me.

I have been owrking on a project for a week and have been very happy with my results.

Largely I am using charts and pivot tables to slice and dice my data.

One of the groups I added for my data was working perfectly well last week.

It ia s Drill group to drill from one code into a larger subset of data.... Nothing complicated very basic.

this week I find that the drill will not skip into the next level.

So when I click on the first level of Drill it just filters the data by the specifc code I clicked on rtaher than drill down.

I tried everything, the Allow Drill setting amongst a swag of other options.

After commenting out a large portion of my code I have stripped the data script back to one single table and still find the drill not working.

To test what was going on I started a whole new project and copied across the script and relaoded.

I then created a new pivot table in the new project and it drilled correctly !

I then thought i must have been the charts in my original project so I copy then across to teh new project... and guess what - they work.

So now I am left scrtaching my head.

I have two prpjects, same script and data source, same Chart and configuration on both charts.

Yet the drill works in one document but does not work in the other.

What is at the document level that may be preventing the drill as it is the only thing I can think is different between the documents.

Any help much appreciated.

1 Reply

I worked it out..... But have a bigger problem on my hands.

The drill was failing because I was using an "Alternate State" on the page.

As soon as I change the settings back to default state the drill starts to work again.

Can someone explain why setting an Aletrnate State has disabled the Drill inside my group please.

Version 11.00.11271.0.SR1