Skip to main content
Announcements
Live today at 11 AM ET. Get your questions about Qlik Connect answered, or just listen in. SIGN UP NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
brunomarques
Contributor III
Contributor III

Error "File not found error" on STORE Command

I have a document that used to work flawlessly on Windows 7 with QV 12.30.20 (November 2018), where a bunch of data is read, filtered and outputted to a csv file using a STORE command.

The same document is not reloading on Windows 10 using the same QV version. It halts on the store command with a wierd "File not found message" with this additonal info :

Cannot open file: '<filename>'
System error: Create directory C failed: boost::filesystem::create_directory: Cannot create a file when that file already exists

The same code works if I specificy a folder as an output that is not an OneDrive folder. Any hints of why this is happening? I need this output to be in a OneDrive folder.

3 Replies
avinashelite

Its not an Qlikview issue I feel ,  after the  windows upgrade your setting are not allowing to overwrite the files with same name because of which your script is failing. Check with your windows teams once and is the issue still persist , help us with the complete log file  

brunomarques
Contributor III
Contributor III
Author

Even when I specify a new filename (meaning it will not overwrite an existing one, I still get the same error) :

2019-06-03 09:25:14 0069 NoConcatenate
2019-06-03 09:25:14 0070 Pairing:
2019-06-03 09:25:14 0071 LOAD
2019-06-03 09:25:14 0072 FileType & DataRow & RecordNr & '[' & DutyNr as DataRow
2019-06-03 09:25:14 0073 Resident RawData
2019-06-03 09:25:14 0074 WHERE DataRowType = 'P'
2019-06-03 09:25:14 1 fields found: DataRow,
2019-06-03 09:25:14 39 806 lines fetched
2019-06-03 09:25:14 0076 STORE Pairing into 'Pairing.csv' (txt)
2019-06-03 09:25:14 Error: Cannot open file: '<Full Path>\Pairing.csv' (System error: Create directory C failed: boost::filesystem::create_directory: Cannot create a file when that file already exists: "<full path>")
2019-06-03 09:25:15 0077 DROP TABLE Pairing

Brett_Bleess
Former Employee
Former Employee

I agree with the prior poster, given this worked in Windows 7, it would appear to be either a group security policy of some sort impacting Windows 10 in your environment, or something that Windows 10 is doing differently in relation to One Drive share etc.  Either way, I would recommend discussing this with the folks in charge of the business One Drive area to see if they can help troubleshoot things.  If you get further info that does point to something we are doing, I would open a support case at that point, so we can then try to replicate the issue and let R&D know if we are able to see the problem as well.  

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.