Skip to main content
Announcements
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Execution of script failed - commented everything but still this

Hi,

I'm developing a complex Dashboard and it worked fine until this morning. After several changes, I always get an "Execution of script failed" error message, and have to reload old data. There is no pop-up error and I can't find anything in the log file. I reverted my last changes one by another to figure out the cause, but no chance, always the same.

I then commented everything except the standard variables for time, currency, etc. There are only the variables still in the document.

What might cause this problem?

Thanks for your help

Jens

8 Replies
Not applicable
Author

please post some sample script. Before that, please check you script if you miss semicolons (;) or brackets.

Please check your file paths

jonathandienst
Partner - Champion III
Partner - Champion III

Hi

Sounds like the file is corrupted. You could attempt to perform a no-data load (which will erase the variable contents as well) to at recover the file. Then set the variables and reload the document.

HTH

Jonathan

Logic will get you from a to b. Imagination will take you everywhere. - A Einstein
Not applicable
Author

Hi,

I solved this, still without knowing what exactly went wrong before.

Currently I'm working for a customer and my own company, so I have two computers and two Qlikview licenses. I opened the qvw file on the other account and was able to reload without any changes made. I then sent this version back and was able to reload on the first machine again.

No clue how this can happen.

Not applicable
Author

HI,

  Even i am facing the same problem.Please help me.

Regards,

Divya

Not applicable
Author

Did you try if Jonathan's approach above works for you?

Not applicable
Author

I have the same issue again - this time the error is related to a script that renames fields that are mentioned in an Excel sheet as input file.

My problem is, that the error does only occur for some fields - for others not. So when e.g. renaming field 'a', works, 'a' and 'b' leads to the error, 'a' and 'c' works.

The working and not working fields are all part of the same table.

Does anyone have an idea what the issue might be? I attached the code for the mapping (renaming).

Many thanks

Jens

st_rives
Contributor II
Contributor II

Hi Jonathan,

it appears I have the same issue with reload data when I comment a part of the script.

Your comment is very interresting and I can see in the log some variables I don't use anymore.

Could you please let me know the process to perform a no-data load ?

Many thanks,

Stephane

Peter_Cammaert
Partner - Champion III
Partner - Champion III

  1. Start QV Desktop.
  2. On the Recent documents list in the Start Page, right-click your document. If it isn't there, open your document first in the normal way and close again.
  3. From the menu, select 'Open 'XXXX' Without Data'.

That's it.

Peter