Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Customer & Partners, DEC. 9, 11 AM ET: Qlik Product & Strategy Roadmap Session: Data Analytics REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
qlikconsultant
Creator II
Creator II

For me the expressions works another user gets an error message

Hi,

I have the following code in a text box.

= only({$<Username = {$(=SubField(OSUser(), '\', 2))} >} USEDEFAULTValue)

For me it works  i get the data.

If another user opens the app. 

They get the error message: "Error: Error in set ad hocelement list: ',' or ')' expected."

Any ideas?

1 Solution

Accepted Solutions
Vegar
MVP
MVP

My best guess is that you have a username without any whitespaces or special characters such as ' ' and '-', but the users with the problem does. 

Try adjusting your expression to either this (case sensitive): 
= only({$<Username = {'$(=SubField(OSUser(), '\', 2))'} >} USEDEFAULTValue) 

or this (case insensitive)
= only({$<Username = {"$(=SubField(OSUser(), '\', 2))"} >} USEDEFAULTValue) 

Plees ekskuse my Swenglish and or Norweglish spelling misstakes

View solution in original post

1 Reply
Vegar
MVP
MVP

My best guess is that you have a username without any whitespaces or special characters such as ' ' and '-', but the users with the problem does. 

Try adjusting your expression to either this (case sensitive): 
= only({$<Username = {'$(=SubField(OSUser(), '\', 2))'} >} USEDEFAULTValue) 

or this (case insensitive)
= only({$<Username = {"$(=SubField(OSUser(), '\', 2))"} >} USEDEFAULTValue) 

Plees ekskuse my Swenglish and or Norweglish spelling misstakes

View solution in original post