Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Support Cases coming to Qlik Community Oct. 4! Start chats, open cases, explore resources: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

How do I show only those fields in list box whose data is present in qlikview?

I have a dimension YEAR which shows values from 2008 to 2015. However the data is available only from 2011-2015. How do I not display those extra values.?

15 Replies
oknotsen
Master III
Master III

Qlik can only show data that is actually in the application, so apparently you DO have data for 2008, 2009 and 2010.

If this is the result of a Master Calendar being created from a too early date, adjust that in your script.

May you live in interesting times!
Not applicable
Author

From 2008 to 2010 it is greyed out. I want to remove the grey values. How should I proceed?

avinashelite

I think your link the date fields from two table that's why you getting additional dates.

You can add a expression in the list box like if(YEAR>='2011',YEAR)

or  you can reduce the data in the script level by applying the where conditions

or

create a extra field in the table where you need to refer the YEAR

avinashelite

go to>list box>in the dimension list > at last you have option called expression>add this

if(YEAR>='2011',YEAR)

raajaswin
Creator III
Creator III

Try Hide excluded optionhide.PNG

Not applicable
Author

Doesn't work Avinash! It creates an extra column in listbox!

Not applicable
Author

With hide excluded it just hides the values....I mean the grey area still stays!

raajaswin
Creator III
Creator III

Hi Harshit,

      What avinash said is correct only. You must have added the expression under expressions tab. Instead give it in the general tab itself.. see the below picture

dd.PNG

now type the expression here and press ok.

Expression to be given: =if(YEAR>='2011',YEAR)

Hope it helps!

Regards

Aswin

avinashelite

try like this :

if(YEAR>='2011',YEAR,null())