Skip to main content

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
QlikWorld 2023, a live, in-person thrill ride. Save $300 before February 6: REGISTER NOW!
cancel
Showing results for 
Search instead for 
Did you mean: 
kamal_sanguri
Specialist
Specialist

How to make sheet available for specific users

Hi All,

I am trying to limit access of a sheet to certain users.

I tried using conditional show property of sheet, but it didn't work. Please help.

Thanks

abc.jpg

1 Solution

Accepted Solutions
tresesco
MVP
MVP

Goto Settings->Document Properties->Security-> Show All Sheets and Objects,  uncheck it.

View solution in original post

10 Replies
Not applicable

Hi Kamal,

using OSuser like that should work fine, check the case or upper everything, might just be a case sensitivity issue.

The other option you have is section access, maybe have a look here

Sheets Security with Section Access

hope that helps

Joe

awhitfield
Partner - Champion
Partner - Champion

Hi,

you are correct with OS user, when you say it's not working, do you mean that the sheet is VISIBLE to all OR HIDDEN?

Andy

OSuser should be in the format DOMAIN\USER

kamal_sanguri
Specialist
Specialist
Author

I used different id's including mine.. but it is always visible..

Although, it should be visible to me only..

kamal_sanguri
Specialist
Specialist
Author

Yes.. I have already checked that .. 

I observed something strange.. When I just copied that condition in new qlikview file.. It started working as it supposed to be..

Any idea what can be the wrong with my exiting qvw.

Thanks

sunilkumarqv
Specialist II
Specialist II

try like this

=IF(OSUser()='UserName',1,0)

tresesco
MVP
MVP

Goto Settings->Document Properties->Security-> Show All Sheets and Objects,  uncheck it.

jebamalai
Specialist
Specialist

Try this

=MixMatch(

osuser(),

'user1',

'user2',

)

>0

kamal_sanguri
Specialist
Specialist
Author

Absolutely..!!

tresesco
MVP
MVP

But 'Absolutely!!' is not the right answer ! Please mark the right one as 'Correct Answer', that would help people find it easily.