Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
QlikWorld 2022, LIVE in Denver CO., May 16-19, 2022. REGISTER NOW TO RECEIVE EARLY BIRD PRICING
cancel
Showing results for 
Search instead for 
Did you mean: 
nikhilgarg
Specialist
Specialist

How to show dimension having no value in bar chart !!

Hey,

I have a dimension Month_Year varying from:

Dec 2013 to Nov 2014

But Jan 2014 and Feb 2014 does not have any value plotted to my bar chart . So it is not shown in bar chart. But client wants Jan 2014 and Feb 2014 too be shown alos.

I cannot find the way to that.

Please help.

Thanks

1 Solution

Accepted Solutions
saumyashah90
Specialist
Specialist

Hi Nikhil,

Click on "Show All Values" just below supress null values

i mean check on "Show all values"

uncheck "Supress Null Values"

View solution in original post

14 Replies
Not applicable

Hello

On the Presentation Tab of the Chart, uncheck Suppress Zero-Values and Suppress Missing values and Click OK.  This should show the months on the x-axis at least.

its_anandrjs

Hi,

Remove Suppress When Value Is NULL option form the chart properties to show rest of the values and if you have used Master calendar with this.

1. Suppress When value is Null From Dimension properties.

2. From Presentation properties Uncheck Suppress Zero-Values.

Regards

Anand

nikhilgarg
Specialist
Specialist
Author

Hey,

I did this but still Jan 2014 and Feb 2014 not shown

Not applicable

Try also uncheckign the Suppress Null value on the dimension tab too please Nikhil

nikhilgarg
Specialist
Specialist
Author

HEy,

Suppress Null value on the dimension tab already uncheck.

What to do ??

I ahve taken dimension as Month_Year .

Expression as :  Sum({<Event = 'Server_DOWN'>}Duration)

But in Jan 2014 and Feb 2014, server was not down. SO its value is 0. So it is not shown here.

But client wants that to be shown

What to do ??

Not applicable

Are you able to attach an example at all? How are the months/dates loaded into your application?

nikhilgarg
Specialist
Specialist
Author

Hey,

It  is not working

nikhilgarg
Specialist
Specialist
Author

PFA

Not applicable

Hi Nikhil,

it is likely that you have no values at all in your underlying data set for those particular months, so you can't simply remove the suppression of zero values (as there isn't any to show). An option for you is to fill in your missing months with some dummy 0 values, so there is real data available in the dimension, and at which point you should be able to uncheck the zero value suppression option.

hope that helps

Joe