Skip to main content
Announcements
Do More with Qlik - Qlik Cloud Analytics Recap and Getting Started, June 19: REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
NZFei
Partner - Specialist
Partner - Specialist

How to turn off prj?

Hello, we do not want the prj folders to be automatically created. Where can I set it off? I have checked the document property and user preferences but could not find the trigger.

Thanks.

1 Solution

Accepted Solutions
NZFei
Partner - Specialist
Partner - Specialist
Author

Hi Andrea,

I have created a ticket and QlikTech has answered that for me as following:

The current issue was identified as bug. Here are alternate solutions to overcome the issue for now.

1. After creating qvw document, please select SAVE option, instead SAVE AS.

or

2. After saving a qvw document, using 'SAVE AS' selection, then rename the document and it opens without
issue.

So basically my colleague always press F12 to SAVE the file AS some name and I always use SAVE. So we have different results.

View solution in original post

6 Replies
Not applicable

Hi

I could be wrong here but I am pretty sure that there is no "setting" that makes the PRJ folder create automatically, this is manual, so you can either create the PRJ folder in the directory where the QVW exists, or not create it.

If the PRJ folder exists, you cannot have one QVW document creating XML versions of its objects, and another QVW document not creating them, the fact that the PRJ folder exists means that all QVW's in that folder will create XML files.

So, short answer to your question is, delete the PRJ folder.

NZFei
Partner - Specialist
Partner - Specialist
Author

Hi Nigel,


Thank you very much for your reply.

It sounds impossible but I have tried in two directories. I deleted all
the prj folders, it works for one directory where even I create a new qvw file,
reload and save, the prj folder does not come out any more. While for the other
directory, I do the exactly same thing, prj folder is still automatically
created.

Fei

agigliotti
Partner - Champion
Partner - Champion

Hi Fei,

I have the same problem, did you solve it?

Thanks and Best Regards

Andrea

NZFei
Partner - Specialist
Partner - Specialist
Author

Hi Andrea,

I have created a ticket and QlikTech has answered that for me as following:

The current issue was identified as bug. Here are alternate solutions to overcome the issue for now.

1. After creating qvw document, please select SAVE option, instead SAVE AS.

or

2. After saving a qvw document, using 'SAVE AS' selection, then rename the document and it opens without
issue.

So basically my colleague always press F12 to SAVE the file AS some name and I always use SAVE. So we have different results.

agigliotti
Partner - Champion
Partner - Champion

Hi Fei,

Take a look at settings.ini file and search for [Settings 7] section, there you should add or modify the parameter name CreateProjectFolder = 0.

Best Regards

Andrea

IAMDV
Luminary Alumni
Luminary Alumni

Thanks Fei. Which version and build are you referring to?

Cheers,

DV