Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Sept. 16, Qlik Product Portfolio Strategy and Roadmap for Data Integration 11 AM ET REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

If no selection - Alternate State

So if there is no Selection in a Multibox with below dimension and alternate state I want a text object not to be displayed.

What is wrong with the condition?

=If(=GetSelectedCount(Concat({[GroupZ]}_Metric))=0, false(), true())

1 Solution

Accepted Solutions
sunny_talwar

Can you try this:


=Len(Trim(GetFieldSelections(_Metric, ',', 100, 'GroupZ'))) > 0

View solution in original post

8 Replies
sunny_talwar

May be try this (not sure what condition you want):

=Len(Trim(Concat({[GroupZ]} _Metric))) > 0

or

=Len(Trim(Concat({[GroupZ]} _Metric))) = 0

avinashelite

try like this

If(GetSelectedCount(Concat({[GroupZ]}_Metric))=0, 0, 1)


paste this expression in the text box properties > Layout > show > conditional

based on the data text box will appear and disappear

Hope this helps you

Not applicable
Author

Well, works out but when plugging it in in the above if condition the text object is not shown when making a selection?!

sunny_talwar

You are using this in the show/hide condition right? If what I just asked is true, then you don't need the if statement. Just use it as is without the if statement

Not applicable
Author

Yes I do: properties > Layout > show > conditional

Still, if I do make a selection in the multibox the text will not show up again.

sunny_talwar

Can you try this:


=Len(Trim(GetFieldSelections(_Metric, ',', 100, 'GroupZ'))) > 0

View solution in original post

Not applicable
Author

Another issue has come across with layout and alternate states and I am not sure whether this is a bug?!

In the attached example I only want to show the multibox if the selection in the list box is right.

This works fine until I define different alternate states for each of the multi boxes as the conditional layout does not work anymore.

For Network I have disabled the conditional layout so you can see the issue.

Is there any solution?

sunny_talwar

Not sure I understand, but can you check now?