Skip to main content
Announcements
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
cancel
Showing results for 
Search instead for 
Did you mean: 
timanshu
Creator III
Creator III

Image in Mail Body through Macro is not displaying

Hi all,

I am trying to send mail with image inserted in body in Outlook.

Syntax:

"<HTML><BODY> <img src=""D:\\ddd.jpg""></BODY></HTML>".

Image is not visible in outlook because Image is not placed on machine which has outlook attached. Rather Image is on server.

If I paste the Image with same name and location of Qlikview Server, I can see the image.

So, How to insert the image in mail body independent of Source Image location.

I am able to add image as attachment. If there is a way to just show that image in body from attachment in outlook. or any other way so that image is visible irrespective of Machine where outlook installed.

I am attaching screenshots of mail when image is present and when not.

Anyone, Please provide a solution to this.

Thanks in advance

4 Replies
timanshu
Creator III
Creator III
Author

Any help?

johanlindell
Partner - Creator II
Partner - Creator II

If you can, place the image on a public web server and use the url to the public image.

timanshu
Creator III
Creator III
Author

Actually, the image is screenshot of a table chart. The image is dynamic for every week and for every user. Therefore cannot do it. any other way ?

marcus_sommer

If I understand the source-code of my test-mail right than is an embedded image in reality a (not displayed) attachment and referenced to the mail per cid like in this example: src="cid:image001.png@". More to this topic could you find here: How to Embed Images in Your Emails: The Facts | SendGrid

- Marcus