Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

cancel
Showing results for 
Search instead for 
Did you mean: 
rash_611
Partner
Partner

Junk value populated in derived fields

Hi Team,

We are facing a issue of junk value getting populated in derived fields. But if reload the same data model multiple times this issue gets rectify. Kindly any one suggest the remedy.

 

Regards,

GR

9 Replies
rash_611
Partner
Partner
Author

We are also getting qlikview engine issue in qmc...

Brett_Bleess
Employee
Employee

Grace, going to need a lot more info in order to even attempt to help on either question.  It would be best to keep one item per post as well so as not to confuse people, just FYI.  Regarding the first issue, you will likely need to attach the app, so folks can see the data model etc. to figure out what you mean to try to offer solutions.  Regarding the QMC item, need further details, but again, I would move one of the two issues to a new thread.  

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
rash_611
Partner
Partner
Author

Thanks for the response. Actually we are having two qvds with same fields and we are concatenating and creating a calender. 

Recently we did server migration to new server and installed QV post that we facing this issue. Values lik "es" or "*yu66ij" which are not there in qvd and getting generated in data model. Help us to solve this...

Brett_Bleess
Employee
Employee

Grace, again, there is not much anyone is going to be able to do to help you unless you can provide a lot more detail here, as I have no idea given what you added.  Ideally, we likely need a lot more detailed description of exactly what you are doing, the use case as well as the app basics and data model and how things are being loaded etc.  

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
rash_611
Partner
Partner
Author

Please refer the attachment. I have provided the case study. 

20190924_193433.jpg

Brett_Bleess
Employee
Employee

This helps, but is not going to give anyone the details we need in order to help I believe, can you attach the QVW file?  That is going to be the fastest way to get the help you want here, as that will allow folks to see the full data model and data to try to figure out from where things are coming.  I really cannot say what is going on from the screenshot of things, need to see the actual data model etc...  You can wait to see if anyone else has any other input, but I really cannot venture much with the additional information.

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
rash_611
Partner
Partner
Author

Actually its sensative... i can't share it...

Brett_Bleess
Employee
Employee

The only way to go at this would be to break things down to try to figure out where they are going wrong.  Run each load statement on its own in a new app to see how the data comes in, so you can validate everything looks good there for each table etc.  If that checks out, then go from there with your concatenation etc., but there should be something in the raw data I believe.  Sorry not more help, but very difficult without the app in this case.

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
rash_611
Partner
Partner
Author

Actually there is no junk value in qvds. If we reload the same data model twice automatically the junk will disappear and correct data will get loaded.... so not able to identify the problem.