Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Legend settings are disabled, why?

Hi,

I am working on a bar chart and on the presentation tab, the legend settings are disabled. "Show Legend" is checked, but I can't adjust the settings such as the font.The ledgend is visible in the chart but with the wrong font, which I would like to fix.

The qvw file was originally created in an older version of QlikView, but is now developed in QV 11.

I don't understand why I can't change the settings? Any help is appreciated.

Thanks,

Magnus

1 Solution

Accepted Solutions
Not applicable
Author

Actually found a way to fix this. The expressions were grouped, and when I ungrouped them I was able to change the legend settings. Weird, but anyway...

View solution in original post

6 Replies
Miguel_Angel_Baeyens

Hi Magnus,

Is that actually a legend or a text within the chart in the Presentation tab of the object properties? Is that the only object not behaving as expected? If so, create a new chart and right click on each expression to copy them to the new one instead of creating it from scratch. You can do likewise with colors and so.

Hope that helps.

Miguel

Not applicable
Author

I am not sure what the alternative would be, but it is an actual expression ledgend. It is showing because I have the "Expression as Legend" checkbox checked in the "Expressions" tab. If I uncheck that box, the legend goes away.

I would really like to avoid re-creating the whole chart just because of this problem...

Thanks,

Magnus

Not applicable
Author

Actually found a way to fix this. The expressions were grouped, and when I ungrouped them I was able to change the legend settings. Weird, but anyway...

phcaptjim
Creator
Creator

I'm having the same problem but my expressions are not grouped.  Any ideas?  This is incredibly frustrating.  I'm using a simple bar chart with one dimension and one expression.  This is really frustrating!  Thanks!

Version: 11.00.11

isciberras
Creator
Creator

How did you ungroup the expression if I may ask? I am facing the same issue however I only have one expression

rosell921
Contributor
Contributor

I'm facing the same issue, anyone found a solution for this?