Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Our next Qlik Insider session will cover new key capabilities. Join us August 11th REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Legends not being shown in line chart

I have a line chart contained within a container. I have two expressions. I have assigned a custom color to each expression. Lines are displayed correctly in the chart. In expressions tab I have option "expression as legend" checked for both expressions but legends are not being displayed.

1 Solution

Accepted Solutions
Anonymous
Not applicable
Author

goto your Chart and press Strg+Shift

you will see boxes surrounded by red lines

move these boxes (especialy the box which seems to be empty - that one of expressions)

and try to move, Change size

maybe you thelegend is outside of visible area

View solution in original post

5 Replies
MindaugasBacius
Partner
Partner

Check if this tick is on:

Screenshot_1.jpg

Anonymous
Not applicable
Author

goto your Chart and press Strg+Shift

you will see boxes surrounded by red lines

move these boxes (especialy the box which seems to be empty - that one of expressions)

and try to move, Change size

maybe you thelegend is outside of visible area

View solution in original post

Not applicable
Author

Yes, it is checked.

Not applicable
Author

Yes, this was the problem, legend was outside. I have changed size, but my legends appears vertical and I want to be horizontal. I solved this by moving, resizing and finally legend was put horizontal automatically. Thanks.

RobertPatrician
Contributor II
Contributor II

One other possibility: If you have your monitor set to a low DPI and your browser (For Qlik Sense) is zoomed in, it won't show the legend unless you zoom your browser out a great deal.